We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Long loading and rendering time after navigation for the first time

Thread ID:

Created:

Updated:

Platform:

Replies:

147695 Sep 20,2019 08:34 AM UTC Sep 23,2019 12:22 PM UTC Blazor 1
loading
Tags: General
Niklas Teich
Asked On September 20, 2019 08:34 AM UTC

Hello!

When i navigate for the first time to a grid example page, the site is not responsing for a few (3-4) seconds, nothing just happens.
After the few seconds, the grid page is displayed and the grid is loading.

After this intial navigating step, the grid page is faster displayed when revisiting it.
So i think there is something happening when visiting the grid page for the first time.
The question is: What is happening and what is blocking the initial navigating step?
Other pages are loading/displayed instantly.

Any ideas to solve this issue are much appreciated!

Greetings,
Niklas


Renjith Singh Rajendran [Syncfusion]
Replied On September 23, 2019 12:22 PM UTC

Hi Niklas, 

Thanks for contacting Syncfusion support. 

We have analyzed your query. We need more details to proceed further on this and provide you a solution as early as possible. Are you referring to the problem like Grid rendered but spinner shows constantly without showing the data in it, or Grid itself is not rendered in the page. Kindly share with us the following details for better assistance. 

  1. Share a video demo showing the problem you are facing.
  2. Share the details about the total records count you are loading.
  3. Have you enabled paging in Grid?
  4. Share the application type(Client/Server) you are using.
  5. Share the details about the type of data(local or remote data from a service) you are loading.
  6. Share the details of the adaptor if you are using any in your application.

The provided information will help us analyze the problem, and provide you a solution as early as possible. 

Regards, 
Renjith Singh Rajendran. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon