We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Grid not working

Thread ID:

Created:

Updated:

Platform:

Replies:

146854 Aug 22,2019 04:34 PM UTC Aug 26,2019 09:03 AM UTC Blazor 10
loading
Tags: Grid
Christoph Weller
Asked On August 22, 2019 04:43 PM UTC

Hi,

Yesterday i have now updated to the latest Blazor beta 17.2.46 and everthing worked fine. Today i started my project and all the data-grids are broken.
Did you change something in the cdn-scripts? Because i get js-errors in the interop.js?



Best regards
Christoph Weller

BigMac
Replied On August 22, 2019 04:50 PM UTC

I have same issue -- I went to bed last night with a grid displaying data and this morning I'm getting same error.  What is going on???



Matthew
Replied On August 22, 2019 06:13 PM UTC

I'm getting the same problems with many other controls including EjsDialog, EjsSchedule and EjsComboBox.
I am using Client-side Blazor

I'm glad others have had the issue. I refactored quite a bit of code today before build & test, then spent the rest of the day trying to work out what I had done wrong.

BigMac
Replied On August 22, 2019 06:21 PM UTC

I noticed they just released (Aug 22) a version of the "ES 2019 Volume 2 SP Release v 17.2.0.46" so I wonder if it is related to problems with their Blazor framework.




ITninja
Replied On August 22, 2019 09:04 PM UTC

It does not look like the newest update has fixed it. As it sits right now, I'm still getting that same ejsInterop.renderComplete error on any pages that use SyncFusion components. One page uses an EjsChart, another page uses a EjsDatePicker, and I've got several others that are doing it. It doesn't disconnect me from the debugger or visual studio, but it does prevent my bindings and events from happening. Expecting this will probably be fixed on the build they plan to release by the end of the month. Any insight on this situation?

Elio
Replied On August 22, 2019 11:03 PM UTC

Same here. I was getting mad because a minute before it was working and then not anymore. I'm quite happy to know I'm not alone.
Probably they changed something in the ej2 min js files that are online and not local

Christoph Weller
Replied On August 23, 2019 05:17 AM UTC

Hello everyone,

Today the error is fixed, no javascript-errors anymore, grids are working. Thank you very much Syncfusion!

Regards
Christoph Weller

Vignesh Natarajan [Syncfusion]
Replied On August 23, 2019 06:36 AM UTC

Hi All, 
  
Query: “Grid not working 
  
We regret the inconvenience caused. We have refreshed the CDN (ej2.min.js) link with the updated script now. Please refer to the CDN link below to resolve the error and also clear the cache before running the application. 
  
  
Regards, 
Vignesh Natarajan. 
 


ITninja
Replied On August 23, 2019 02:26 PM UTC

Hey Vignesh,

I've done as instructed and updated the CDN (I already had that same address, but I copied and pasted it in anyway in case I was missing something), closed Visual Studio, cleared my cache using a nuget.exe file with the command 'nuget locals all -clear', cleared my temp folder, and deleted the following folder: "%USERPROFILE%\AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache"

I still get the same issue with ejsInterop.renderComplete on any page that uses a Syncfusion component unfortunately.

Thank you guys for being so quick to read these posts and get the problems fixed! It is greatly appreciated.

Here is another screenshot of the full error:

Attachment: EjsError_32146d2f.7z

Elio
Replied On August 23, 2019 02:31 PM UTC

Hey Vignesh,

I've done as instructed and updated the CDN (I already had that same address, but I copied and pasted it in anyway in case I was missing something), closed Visual Studio, cleared my cache using a nuget.exe file with the command 'nuget locals all -clear', cleared my temp folder, and deleted the following folder: "%USERPROFILE%\AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache"

I still get the same issue with ejsInterop.renderComplete on any page that uses a Syncfusion component unfortunately.

Thank you guys for being so quick to read these posts and get the problems fixed! It is greatly appreciated.

Here is another screenshot of the full error:

Attachment: EjsError_32146d2f.7z

You have to delete your browser cache (for example Chrome)

Renjith Singh Rajendran [Syncfusion]
Replied On August 26, 2019 09:03 AM UTC

Hi ITninja, 

Thanks for your update. 

As suggested by Elio, we would also suggest you to clear the Browser cache to resolve the problem you are facing.  

Please get back to us if you need further assistance. 

Regards, 
Renjith Singh Rajendran. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon