We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Server error when deploying to production

Hello Syncfusion,
I am receiving a server error after I've deployed to my clients production servers. I've attached the image. Looks like something to do with the licensing. Please get back to me when you can, thanks!

Attachment: Screen_Shot_20190807_at_2.03.35_PM_ba205815.zip

1 Reply

BR Balaji Renganathan Syncfusion Team August 12, 2019 11:13 PM

Hi Hatem, 

Thanks for contacting Syncfusion support! 

Starting with v16.2.0.x if you are using Syncfusion nuget packages, you also have to include a license key in your projects. Follow the below article to know about how to generate license keys for specific version and platform,   

  
Follow the below user guide document to know about registering the license keys in your project.   



Please ensure the below items in your projects before deploying the application 

  • Ensure all the referenced Syncfusion assemblies are on same version,
  • Ensure the Syncfusion.Licensing.dll assembly version which is referred in the project is also deployed in the production server.
  • Our license keys are platform and version specific, so please ensure corresponding version and platform license are applied in your projects

If you are still facing the same issue, please share us the following details for further investigation at our end.    

1. Syncfusion NuGet packages\assemblies and its version used in your project  
2. Syncfusion license key used in your application.  
 
Regards, 
Balaji R 


Loader.
Live Chat Icon For mobile
Up arrow icon