We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

All OS specific controls aren't compatible with NetStandard2.0

All controls that are os specific, such as sfpicker.Android/IOS cannot be installed.

Following error:
```
Package Syncfusion.Xamarin.SfPicker.Android 17.2.0.36 is not compatible with netstandard2.0 (.NETStandard,Version=v2.0). Package Syncfusion.Xamarin.SfPicker.Android 17.2.0.36 supports: monoandroid10 (MonoAndroid,Version=v1.0)
```



1 Reply

MK Muneesh Kumar G Syncfusion Team July 29, 2019 01:44 AM

Hi Tigrish, 
 
Greeting from Syncfusion.  
 
We have analyzed your query, based on provided information and we suspect that you have referred the native nugets in Xamarin.Forms project, so only the reported error occurs. For Xamarin.Forms you have to use Syncfusion.Xamarin.SfPicker only in all the Xamarin.Forms projects. 
 
For more information please refer the following link. 
 
Please let us know, if you face any problem. 
  
Regards, 
Muneesh Kumar G.  
 


Loader.
Live Chat Icon For mobile
Up arrow icon