We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

VLOOKUP returns #N/A

Thread ID:

Created:

Updated:

Platform:

Replies:

145823 Jul 9,2019 04:52 PM UTC Jul 19,2019 01:39 PM UTC WinForms 3
loading
Tags: XlsIO
Matthew Smith
Asked On July 9, 2019 04:52 PM UTC

I am trying to import the data from a spreadsheet which has columns that use VLOOKUP. I am able to detect the formula and have enabled sheet calculations. However, the calculated value that is return is #N/A. The documents states VLOOKUP is supported yet I cannot get back the correct text displayed in the actual spreadsheet when viewed in Excel.

Does VLOOKUP actual work within XlsIO?  

Abirami Varadharajan [Syncfusion]
Replied On July 10, 2019 03:48 PM UTC

Hi Matthew, 
 
Greetings from Syncfusion. 
 
Yes, VLOOKUP is supported in XlsIO. We are unable to reproduce the issue and we suspect that the issue occurs with specific document/formula. 
 
We are sharing the sample which we have tried at our end for your reference which can be downloaded from following link. 
 
  
Please modify the sample to reproduce the issue and get back to us with an issue reproducing sample which will be helpful for us to analyse further and to provide prompt solution.  
 
Regards, 
Abirami 


Matthew Smith
Replied On July 18, 2019 09:52 PM UTC

Abirami,

Sorry for the delay. I found the route cause of why the VLOOKUP was not working within XlsIO.

The target spreadsheet is version of a Google Spreadsheet which was linked to a external data source. The cell which the VLOOKUP was referencing which was in a separate workbook in the spreadsheet had a formula like this:

=IFERROR(__xludf.DUMMYFUNCTION("""COMPUTED_VALUE"""),"R5 Disc Red eTap")

I think this is the reason why the VLOOKUP failed and returned NULL.

Abirami Varadharajan [Syncfusion]
Replied On July 19, 2019 01:39 PM UTC

Hi Matthew, 

Thank you for updating us. 

We are getting incorrect calculated value(i.e., #VALUE!) is returned for the cell which has VLOOKUP formula and referring the external workbook. Also, we are not getting the calculated value as #N/A or null as per your update.  

However, the issue has been resolved in our release version 16.3.0.21. You can also refer the latest NuGet from following link to your application to ensure the same.    


Please find the sample which we have tried at our end. 


If your scenario from this or the issue reproducing with latest NuGet, kindly modify the sample to reproduce the issue and get back to us with an issue reproducing sample which will be helpful for us to provide prompt solution at the earliest. 

Regards, 
Abirami 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon