We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

filters with tree view

Kindly find attached for the tree view sample codes and follow the below steps.

Step to do:

1. First select the parent Australia
Now all children under Australia selected automatically
2. Now in search type "acre".It works fine.
3. Now clear filter
4. Un-check New South Wales, Victoria, south Australia and western Australia
5. Now u can see Brazil, Parana, Ceara, Acre checked
6. Now in search bar type "a"
7. you can see all children under Austrralia is checked.

The output shown is wrong,
Because i have unchecked the New South Wales, Victoria, south Australia and western Australia, how it got selected/checked.


Attachment: angulartg9bew9at2bu_d747bb84.zip

5 Replies

CI Christopher Issac Sunder K Syncfusion Team April 5, 2019 11:50 AM UTC

Hi Ebenezer, 

Greetings from Syncfusion!!! 

We have validated your reported issue. You can overcome this issue by disabling loadOnDemand property. We have attached the updated sample. 

Please check the sample and let us know if you have any concerns. 


EB Ebenezer April 5, 2019 01:41 PM UTC

Thanks Christo,

I checked your sample codes, disabling loadOnDemand, not fixed my issue.
Kindly go through the steps that i mentioned in previous issue.
Unchecked items got selected. why?


BM Balachandar Murugesan Syncfusion Team April 8, 2019 12:34 PM UTC

Hi Ebenezer,  

Sorry for the inconvenience caused.  
We have followed the steps as you provided in your first update. But we were unable to reproduce the issue in that case. Please check the image 
But while following the below steps we can able to reproduce the issue which is reported by you 
1.       1. After unchecking the New South Wales, Victoria, south Australia and western Australia, we again type acre in search box. 
2.       2. Now acre with its corresponding parent Nodes get checked 
3.       3. After clearing the filter, we found that all the nodes under Australia get checked. 
We overcome this issue by maintaining the indeterminate nodes in separate array and make it check only when it is changed by user interaction. 
 Note: You can disable the autoCheck property to achieve the independent checked state of parent and child Nodes 
Please check the sample and get back to us if we misunderstood your query or need any further assistance. 
Balachandar M. 

EB Ebenezer April 9, 2019 05:46 AM UTC

Thanks Bala,

It works perfect on acre search.

Now check/select bihar under India,
Again do search "Bihar"
Bihar got unselected.why?


CI Christopher Issac Sunder K Syncfusion Team April 9, 2019 01:27 PM UTC

Hi Ebenezer, 

Thanks for the update. 

We have resolved the issue in the previously provided sample. Also maintained the expanded Nodes after search via expandedNodes property. 

Please check the updated sample from below link 

Please let us know if you have any concerns and need any further assistance. 


Live Chat Icon For mobile
Up arrow icon