We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Error and failed while installing through npm

I tried to install through following command and it end up with the error, can  you please check what can be the issue.

Command: npm install @syncfusion/ej2-angular-schedule --save
npm WARN @agm/core@1.0.0-beta.5 requires a peer of @angular/common@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @agm/core@1.0.0-beta.5 requires a peer of @angular/core@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-charts@7.4.0 requires a peer of @angular/common@5.x but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-charts@7.4.0 requires a peer of @angular/core@5.x but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-charts@7.4.0 requires a peer of @angular/animations@5.x but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-charts@7.4.0 requires a peer of @angular/platform-browser@5.x but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-charts@7.4.0 requires a peer of rxjs@5.x but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-datatable@13.1.0 requires a peer of @angular/common@<7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-datatable@13.1.0 requires a peer of @angular/compiler@<7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-datatable@13.1.0 requires a peer of @angular/core@<7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-datatable@13.1.0 requires a peer of @angular/platform-browser@<7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-datatable@13.1.0 requires a peer of @angular/platform-browser-dynamic@<7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN angular-datatables@6.0.1 requires a peer of @angular/common@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN angular-datatables@6.0.1 requires a peer of @angular/compiler@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN angular-datatables@6.0.1 requires a peer of @angular/core@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN angular-datatables@6.0.1 requires a peer of @angular/platform-browser@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN angular-datatables@6.0.1 requires a peer of @angular/platform-browser-dynamic@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN bootstrap@4.3.1 requires a peer of popper.js@^1.14.7 but none is installed. You must install peer dependencies yourself.
npm WARN codelyzer@4.2.1 requires a peer of @angular/compiler@>=2.3.1 <7.0.0 || >6.0.0-beta <7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN codelyzer@4.2.1 requires a peer of @angular/core@>=2.3.1 <7.0.0 || >6.0.0-beta <7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN codelyzer@4.2.1 requires a peer of @angular/platform-browser-dynamic@>=2.3.1 <7.0.0 || >6.0.0-beta <7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN codelyzer@4.2.1 requires a peer of @angular/platform-browser@>=2.3.1 <7.0.0 || >6.0.0-beta <7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN codelyzer@4.2.1 requires a peer of @angular/common@>=2.3.1 <7.0.0 || >6.0.0-beta <7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ng-multiselect-dropdown@0.2.3 requires a peer of @angular/common@^4.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ng-multiselect-dropdown@0.2.3 requires a peer of @angular/core@^4.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ng2-smart-table@1.3.5 requires a peer of @angular/common@^6.0.1 but none is installed. You must install peer dependencies yourself.
npm WARN ng2-smart-table@1.3.5 requires a peer of @angular/core@^6.0.1 but none is installed. You must install peer dependencies yourself.
npm WARN ng2-smart-table@1.3.5 requires a peer of @angular/forms@^6.0.1 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-aside@1.4.2 requires a peer of @angular/common@^6.0.0-rc.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-aside@1.4.2 requires a peer of @angular/core@^6.0.0-rc.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-aside@1.4.2 requires a peer of @angular/animations@^6.0.0-rc.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-quill@3.6.0 requires a peer of @angular/core@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-quill@3.6.0 requires a peer of @angular/forms@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-toastr@8.10.2 requires a peer of @angular/core@^5.2.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-toastr@8.10.2 requires a peer of @angular/common@^5.2.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-toastr@8.10.2 requires a peer of @angular/platform-browser@^5.2.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.7 (node_modules\@angular\compiler-cliode_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.7: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

npm ERR! code UNKNOWN
npm ERR! errno -4094
npm ERR! syscall fsync
npm ERR! UNKNOWN: unknown error, fsync

1 Reply

KK Karthigeyan Krishnamurthi Syncfusion Team March 20, 2019 12:46 PM UTC

Hi Sajid,


Thank you for contacting Syncfusion support.

We suspect that npm /node module is not installed properly which could be the cause for the issue. Kindly share your package file / sample (if possible) to proceed further.


Regards,
Karthi

Loader.
Live Chat Icon For mobile
Up arrow icon