We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Avoid Connector line overlapping on nodes

Thread ID:

Created:

Updated:

Platform:

Replies:

142491 Feb 6,2019 12:17 PM UTC Feb 11,2019 08:52 AM UTC WinForms 7
loading
Tags: Diagram
Unknown
Asked On February 6, 2019 12:17 PM UTC

Hi,

Currently we are evaluating syncfusion for winform diagram now we are facing connector line overlapping on nodes issue.Please help us to how to avoid connector line overlapping on nodes.


Thanks in advance

Thanks & Regards,
Sumit




Aravind Ravi [Syncfusion]
Replied On February 7, 2019 06:53 AM UTC

Hi Sumit, 
 
To avoid connector overlapping on node set LineRoutingEnabled as true in diagram model.  Please find below UG documentation link for how to avoid connector overlapping on nodes 
 
 
Regards 
Aravind Ravi 
 
 


Unknown
Replied On February 7, 2019 07:28 AM UTC

Hi Arvind,

Thanks for update

I have already set LineRoutingEnabled as true in diagram model but still connector overlapping on nodes when moving selected node of diagram to another position.

Please help us for this issue.

Thanks & Regards,
Sumit

Aravind Ravi [Syncfusion]
Replied On February 7, 2019 01:02 PM UTC

Hi Sumit, 
 
Could you please provide us a screen shot that how does connector overlap on Node. This will help us to serve you better. 
 
Regards 
Aravind Ravi 
 
 


Unknown
Replied On February 8, 2019 04:47 AM UTC

Hi Aravind ,

I have attached screen shot of overlapping connector on node with this mail.

PFA

Thanks & Regards,
Sumit

Attachment: ScreenShotOvelappingConnector_90cc09e4.zip

Aravind Ravi [Syncfusion]
Replied On February 8, 2019 09:27 AM UTC

Hi Sumit, 
 
Please set RoutingMode as Automatic in diagram model LineRouter as mentioned in below code snippet 
 
diagram1.Model.LineRouter.RoutingMode = RoutingMode.Automatic; 
 
For more details about Line routing mode please find the Distance and Routing Mode settings section in below UG documentation link 
 
 
In case if the issue still persists,  kindly revert. 
 
Regards 
Aravind Ravi 
 


Unknown
Replied On February 8, 2019 11:10 AM UTC

Hi Aravind,

Thanks for update

I have set  diagram1.Model.LineRouter.RoutingMode = RoutingMode.Automatic property in diagram model but still issue persists.

Please find attached screen shot.

Thanks & Regards,
Sumit




Attachment: ScreenShot_4d1012e2.zip

Ramya Thirugnanam [Syncfusion]
Replied On February 11, 2019 08:52 AM UTC

Hi Sumit, 
 
The Routing does not consider or support the connector with corner radius. We have confirmed and logged this as a feature request in our database. We will implement this feature in any of our upcoming releases. We will update you when this feature has been implemented.   
 
Now, you can now track the status of your request, review the proposed resolution timeline, and contact us for any further inquiries through the below link.  
  
 
 
 
Regards, 
Ramya T 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon