We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

RE: Running Sqoop

Thread ID:

Created:

Updated:

Platform:

Replies:

142051 Jan 16,2019 05:47 PM UTC Jan 21,2019 12:39 PM UTC Big Data Platform 3
loading
Tags: Big Data Studio
Venkatesh
Asked On January 16, 2019 05:47 PM UTC

Hi,

This is Venkatesh and I've been using your product for my hadoop and spark hands on practises on windows. I've to say, it is very helpful. 

But, lately have been experiencing issues with running sqoop commands from either of powershell, command shell or from the sqoop section in the big data studio.

I've mysql workbench installed on my local pc. But, whenever I run a sqoop command, it says 'Connection to the database server' not established.

I've already installed the connectors and placed them inside sqoop/lib folder.

When I connect to mysql DB, I was able to connect with the username and password.

Please find the screenshots for your reference.

Kindly let me know if I'm missing something.

Thanks,
Venkatesh Raman

Attachment: Sqoop_Failure_ceb1f89a.7z

Mallieswari D [Syncfusion]
Replied On January 17, 2019 01:16 PM UTC

Hi Venkatesh, 

Thanks for contacting Syncfusion support. We have checked the logs attached and we suspect that the issue may be due to mysql connector used in ‘Sqoop\lib’ is incompatible with mysql server version 8.0.13 running in your machine. Download MySql connector jar 8.0 from here and replace the downloaded JDBC connector jars to Sqoop\lib folder. 
 
 
Here is a sqoop sample executed in command shell which list the database from mysql server: 

 


Regards, 

Mallieswari D 



Venkatesh
Replied On January 18, 2019 12:08 PM UTC

Hi,

Thanks. I downloaded mysql-connector-java-8.0.13 and it was resulting in version mismatch 'java.lang.UnsupportedClassVersionError: com/mysql/jdbc/Driver : Unsupported major.minor version 52.0' issues, so I tried 5.1.47 and the sqoop commands between mysql and hdfs seem to be working fine. But, when I use hive import, I'm getting a jline error. Kindly let me know if I'm missing something.

Thanks,
Venkatesh Raman

Attachment: Hive_Import_Error_5092bbea.7z

Dinesh Kumar P [Syncfusion]
Replied On January 21, 2019 12:39 PM UTC

Hi Venkatesan, 
  
Please let us know whether you have tried out Hive import via Big Data Studio application. Because Jline jar references were already handled in Big Data Studio. You can check the following link to know more about submitting a Sqoop job via Big Data Studio. 
  
Also, we couldn’t find any files in your attachment. If you still face any problem, please let us know. 
  
Regards, 
Dinesh Kumar P 



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;