We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Error while running the app in device

Thread ID:

Created:

Updated:

Platform:

Replies:

141729 Dec 31,2018 09:57 AM UTC Jan 3,2019 04:17 AM UTC Xamarin.Forms 4
loading
Tags: SfComboBox
Sadhik
Asked On December 31, 2018 09:57 AM UTC

I am getting the following error while running in physical device, for simulator it works fine.

Severity Code Description Project File Line Suppression State
Error Can't resolve the reference 'System.Func`2<System.String,System.String> Xamarin.Forms.Internals.ResourceLoader::get_ResourceProvider()', referenced from the method 'System.Void Syncfusion.XForms.ComboBox.SfComboBoxStyles::InitializeComponent()' in 'Xamarin.Forms.Core, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null'. CUCA.Mobile.iOS


Please find the attached screenshot



Attachment: Capture_623fe114.zip

Sadhik
Replied On January 2, 2019 08:22 AM UTC

Please do reply as I am not able to archive the build for distribution, after development.

Dhanasekar R [Syncfusion]
Replied On January 2, 2019 11:28 AM UTC

Hi Sadhik, 
 
Greetings from Syncfusion. 
 
We have validated with the simple combobox sample and we are unable to reproduce the reported issue in real device. We have provided the working sample of combobox below. Please have the same from the below link. 
 
 
Please try our above sample and check whether you could reproduce the reported issue from your side. 
 
Also Ensure the following in your project 
 
1.    Ensure whether you are using the common Xamarin.Forms version (above 3.0.0.446417) for all the project (PCL and iOS project).  
2.    Ensure you have included Syncfusion.Xamarin.Core NuGet in iOS Project 
 
 
Regards, 
Dhanasekar 


Sadhik
Replied On January 2, 2019 02:48 PM UTC

Dear Dhanasekar ,

The issue was resolved after uninstalling and installing the Nuget package.
Thank you for your support.

Regards,
Sadhik Badarudeen

Dhanasekar R [Syncfusion]
Replied On January 3, 2019 04:17 AM UTC

Hi Sadhik, 
 
Thanks for the update.   
   
Glad that the issue has been resolved. Please let us know if any further assistance on this.   
   
Regards,   
Dhanasekar   


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;