We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Hide header panel of the dockedwindow

Thread ID:

Created:

Updated:

Platform:

Replies:

141661 Dec 26,2018 07:23 AM UTC Jan 3,2019 10:50 AM UTC WPF 5
loading
Tags: DockingManager
Amari Mecheri
Asked On December 26, 2018 07:25 AM UTC

Hello,

In the DockingManager I would like to hide the header panel (no button, no context menu) on top of the Window when it is the only window. I have tried HideTDIHeaderOnSingleChild which removes the tab header but not the panel. I also removed the close button but I haven't found how to remove the remaining context menu (which displays only the header of the one window).

Thank you.

Amari Mecheri
Replied On December 30, 2018 08:27 AM UTC

hello,

The picture below is from the documentation "MDI/TDI functionnalities of Syncfusion DockingManager control for wpf  - Hiding TDI header". It shows the problem I'm facing. In this case, there is only one window the header is hidden. As I don't want the window to be closed nor dragged I would like also to remove the panel that sits on top of the window


I would like the same behaviour as the clientControl but only when there is only 1 window. If there is more than 1 window, the headers would be displayed and every window, except the first one, could be dragged, closed, etc...


Thank you for your help.

Jagadeesan Pichaimuthu [Syncfusion]
Replied On January 2, 2019 08:45 AM UTC

Hi Amari Mecheri, 
 
Thank you for contacting Syncfusion support. 
 
We have checked your query "How to hide header panel of DocumentTabControl in DockingManager ". We have prepared sample based on your requirement in which we have restricted close and dragging functionalities for the first tab by setting CanClose and CanFloat attached property of Docking Manager as false when it contain more than one tab items in DocumentTabControl  and also hide the header panel of DocumentTabControl when it contain only one tab item by setting following property of Docking Manager ShowTabListContextMenu as false, HideTDIHeaderOnSingleChild as true and DocumentCloseButtonType as hide. Please download the same from the below location. 
   
If we misunderstood your requirement, please provide more information regarding the requirement. This would help us to proceed further. 
 
Regards, 
Jagadeesan

Amari Mecheri
Replied On January 2, 2019 10:31 AM UTC

Hi Jagadeesan,

This is what i was looking for. Thank you for your help. ShowTabListContextMenu does what I was looking for.

May I ask you how I can remove all the space (margins) around the "client control" window. When it's the only Window, I'd like it takes all the available space.


Thank you very much.

Regards
Amari


Jagadeesan Pichaimuthu [Syncfusion]
Replied On January 3, 2019 08:56 AM UTC

Hi Amari, 
 
Thank for your update. 
 
We have checked your query "How to disable border around the DocumentTabControl when it contain single tab item". We have prepared sample based on your requirement in which we have set the border of DocumentTabControl by using its BorderThickness property based on its tab items count. Please download the same from the below location. 
   
Please try this above solution and let us know if it is helpful.  
 
Regards, 
Jagadeesan 


Amari Mecheri
Replied On January 3, 2019 10:50 AM UTC

Hi Jagadeesan,

Thank you for your quick answer. This is exactly what i was looking for.

Thanks alot for your support.

Best regards
Amari



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;