We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

No Way to resolve conflict

Thread ID:

Created:

Updated:

Platform:

Replies:

147504 Sep 15,2009 12:15 AM UTC Sep 13,2019 10:56 AM UTC Others 5
loading
Tags: Others
David Wier
Asked On September 15, 2009 12:15 AM UTC

I'm using 7.102.0.21 - all my references point to that version
my app config has this:





I still have this message in the error list when I build:
Warning 25 No way to resolve conflict between "Syncfusion.Core, Version=7.102.0.21, Culture=neutral, PublicKeyToken=632609b4d040f6b4" and "Syncfusion.Core, Version=6.403.0.15, Culture=neutral, PublicKeyToken=632609b4d040f6b4". Choosing "Syncfusion.Core, Version=7.102.0.21, Culture=neutral, PublicKeyToken=632609b4d040f6b4" arbitrarily.

and then:
Warning 26 Found conflicts between different versions of the same dependent assembly.

When I run the ResX converter, it errors out saying it can't load Syncfusion.Shared.Base, but it's in the GAC - - I'm lost

How can I fix this?

Vijayakumar S [Syncfusion]
Replied On September 15, 2009 04:09 AM UTC

Hi David,

Thank you for posting your query.

Could you please try removing the assemblies of all versions from GAC and install only 7.1.0.21 versioned assemblies. Please have a look at the document in the below link, which describes the steps to remove the assemblies of all versions and installing 7.1.0.21 versioned assemblies. Let us know if this helps.

http://files.syncfusion.com/support/DocIO.Windows/F90026/Procedure.zip

Please let us know if you have any questions.

Regards,
Vijay

David Wier
Replied On September 19, 2009 11:07 PM UTC

Sorry - but that didn't work -
the assembly manager only installed the 3.5 assemblies to the GAC
I get this:Framework v2.0 has been detected.
Installing Prebuilt assemblies to GAC...
File d:\Program Files\Syncfusion\Essential Studio\7.1.0.21\PreCompiledAssemblies\7.1.0.21\2.0\syncfusion.server.silverlight.dll is not available on disk
File d:\Program Files\Syncfusion\Essential Studio\7.1.0.21\PreCompiledAssemblies\7.1.0.21\2.0\syncfusion.tools.silverlight.dll is not available on disk
File d:\Program Files\Syncfusion\Essential Studio\7.1.0.21\PreCompiledAssemblies\7.1.0.21\2.0\syncfusion.gauge.silverlight.dll is not available on disk
Done.

but all I see in the GAC are 7.103 versions

I still get the errors

I copy the dlls I need to an "Install Files" folder, near my project, and add them as references from there.

I'm only using 2.0 assemblies, since I want my application to work with either 2.0 or 3.5

this is getting old, not having an easy way to add dlls to projects

Vijayanand S [Syncfusion]
Replied On September 23, 2009 07:05 PM UTC

Hi David,

Sorry for the long delay in getting back to you.

We had an issue with assembly manager which will not deploy the assemblies into GAC if you have only VS 2008 in your machine. We have fixed the issue and the fixed assembly manager tool is available in attachment of this post. Please deploy this tool in the following location and try to deploy the assemblies.

[Installed Drive]:\Program Files\Syncfusion\Essential Studio\[Installed Version]\Utilities\Assembly Manager

Please let me know if this works.

Regards,
Vijay



assemblymanagerwindows_53d9c8d8.zip

Sebastian
Replied On September 11, 2019 05:19 PM UTC

Hi, I had the same problem

System.IO.FileLoadException
  HResult=0x80131040
  Message=No se puede cargar el archivo o ensamblado 'Syncfusion.Shared.Base, Version=17.2460.0.51, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89' ni una de sus dependencias. La definición del manifiesto del ensamblado no coincide con la referencia al ensamblado. (Excepción de HRESULT: 0x80131040)
  Source=<Cannot evaluate the exception source>
  StackTrace:
<Cannot evaluate the exception stack trace>

Inner Exception 1:
FileLoadException: No se puede cargar el archivo o ensamblado 'Syncfusion.Shared.Base, Version=17.2460.0.46, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89' ni una de sus dependencias. La definición del manifiesto del ensamblado no coincide con la referencia al ensamblado. (Excepción de HRESULT: 0x80131040)

In order to fix it, I edited de app.config and remove this lines, and it works!

<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="Syncfusion.Shared.Base" publicKeyToken="3d67ed1f87d44c89" culture="neutral"/>
        <bindingRedirect oldVersion="0.0.0.0-17.2460.0.51" newVersion="17.2460.0.51"/>
      </dependentAssembly>
</assemblyBinding>


I´m not sure about the consecuences of editing de app.config, could you tell if it's a goog solution?
Thanks!

Vadivel Natarajan [Syncfusion]
Replied On September 13, 2019 10:56 AM UTC

Hi Sebastian, 

Thanks for contacting Syncfusion support.  

We suspect that this issue occurred due to the multiple versions of Syncfusion assemblies referred in your application. Please ensure all the Syncfusion assemblies referred in your application (.csproj, packages.config) are on the same version. If multiple version assembly referred, then remove the unwanted version reference and reference the required version assembly to resolve this issue than to remove the bindingRedirect line in app.config file.  

Let us know if this helps you.  

Regards, 
Vadivel Natarajan   


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon