We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Could not load file or assembly

Thread ID:

Created:

Updated:

Platform:

Replies:

126984 Oct 19,2016 12:21 PM Oct 21,2016 12:44 AM Windows Forms 3
loading
Tags: ButtonAdv
Matthijs de Zwart
Asked On October 19, 2016 12:21 PM

Hi,
I had some problem similar to this one:https://www.syncfusion.com/forums/54790/error-after-adding-components-to-toolbar
Therefor I followed the advice and removed the references and added them via References ==> Add reference ==> extensions ==> and picked the latest versions of the following files.

Syncfusion.Chart.Base
Syncfusion.Chart.Windows
Syncfusion.Shared.Base
Syncfusion.Tools.Windows
I was able to drag and drop for instance a buttonAdv on the winform. But I tried to build the application, and then I got this message:
"Could not load file or assembly 'Syncfusion.Tools.Windows, Version=14.2460.0.26, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89' or one of its dependencies. The system cannot find the file specified."

Why is it still referencing to an old (uninstalled) version, instead of the file I just added via add reference? And now I cannot build, save or check in my work.
please advice.
Kind regards,
Matthijs

Keerthana Jegannathan [Syncfusion]
Replied On October 20, 2016 02:29 AM

Hi Matthijs,     
     
Thank you for contacting Syncfusion Support.      
      
We suspect that the GAC assemblies were not properly configured or previous version of Syncfusion assemblies were not removed properly from your machine. Please refer to the below link to ensure whether the GAC assemblies are installed properly in your machine.      
      
      
And also ensure whether the Syncfusion controls are configured properly for the .NET Framework version using the below steps:     
   
Step 1:    
   
·        Close your application and clear bin/obj files.    
·        Open Essential Studio and then select Utilities.   
   
     
   
Step 2:   
Select Assembly Management and then select Assembly Manager Launch option.   
   
    
   
Step 3:   
 Remove all the installed versions from your machine.   
   
    
   
Step 4:   
 Select the Installed version and framework.   
   
     
   
Step 5:   
 Select Perform Action to start the installation of controls.    
   
     
   
     
Step 6:     
Please close the application and clean the bin and obj folder of your application and rebuild the project again and make sure that the Syncfusion assemblies are properly referred to and try to use ButtonAdv in Form Designer.      
     
If the above solution doesn’t help, please close the application and clean the bin and obj folder of your application and rebuild the project again. Delete the mentioned control from your Toolbox and add it again using the following steps.     
     
Step 1:     
 Delete the Button from Toolbox as mentioned in the screenshot.     
   
     
   
Step 2:     
 Add it again as mentioned in the screenshot.     
   
     
   
Step 3:     
Add ButtonAdv based on the Framework you haved used in your Visual Studio as mentioned in the screenshot.     
   
     
    
Step 4:     
The ButtonAdv will be added in ToolBox and it should be working properly now.      
     
Please do the above and let us know if it helped.    
     
Regards,      
Keerthana J.   


Matthijs de Zwart
Replied On October 20, 2016 03:28 AM

Thanks for the help!

Keerthana Jegannathan [Syncfusion]
Replied On October 21, 2016 12:44 AM

  
Hi Matthijs,   
We are glad that your problem has been resolved. Please let us know if you need further assistance. 
Regards, 
Keerthana J. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;