We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

crop problem

Hi
sf image editor crop work well in android but in ios crop has a problem.
when I pick image from gallery crop opration doesn't work well and it crop image in wrong position size.
some time rotate the picture!!!!
I use the last version of sfimageeditor


10 Replies

MO Morteza January 15, 2019 11:41 AM

Any Help?! :(


MP Michael Prabhu M Syncfusion Team January 16, 2019 03:05 AM

Hi Morteza, 
 
Greetings from Syncfusion, we can able to reproduce the cropping issue after rotation at our end and we have logged a defect report and you can keep track of this from the below link. 
 
  
At Syncfusion, we are committed to fixing all validated defects (subject to technological feasibility and Product Development Life Cycleand including the defect fix in our subsequent weekly NuGet release which is scheduled on every Tuesday of the week and you can expect this fix on 23rd January 2019 weekly NuGet release. If you wish to receive this fix in a specific prior release product version please revert back to us(backwards compatibility subject to technological feasibility and our Support SLAYou can now track the current status of your request, review the proposed resolution timeline,  and contact us for any further inquiries from the above link. We appreciate your patience until then.  
 
Thanks, 
Michael 
 



CC CT CHANG January 21, 2019 06:36 AM

Yeah, I have the same problem too. Look after for the next update : )


BK Bharathiraja K Syncfusion Team January 22, 2019 01:29 AM

Hi Morteza, 
 
We regret for the inconvenience caused. 
 
Due to the technical complexity of the issue, we are unable to include this fix in our 22nd January,2019 weekly NuGet. We will include this fix in our upcoming weekly NuGet release which is scheduled to be on 29th January 2019. We appreciate your patience until then.  
 
Thanks, 
Bharathiraja. 



NG Neil Gupta January 22, 2019 06:28 AM

I'm having the same issue, waiting for the next update


BK Bharathiraja K Syncfusion Team January 22, 2019 10:33 PM

Hi Neil Gupta, 
 
We will update you once rolled out our weekly Nuget on 29th January 2019. Thanks for your patience until then. 
 
Thanks, 
Bharathiraja. 



BK Bharathiraja K Syncfusion Team January 23, 2019 02:14 AM

Hi Stephane 
 
Greetings from Syncfusion, we have tried to replicate the reported issue at our end by creating a simple sample, we are afraid that we are not able to reproduce the issue at our end. We have tested the below mentioned scenarios and used ObservableCollectiont to bind data.  
 
1. Tested by removing data one by one and added new data dynamically using button click.  
2. Tested by clear the data collection and adding new data dynamically.  
3. Tested without setting any minimum and maximum value for the DateTimeAxis. 
 
Please find the tested sample below.   
 
Since we are not aware of your exact application scenario, we were not able to reproduce this issue at our end, so can you please revert us by modifying the sample based on your application along with replication procedure. This will be helpful for us to investigate further and provide you a better solution at the earliest. And update the SfChart to latest version and check once whether the issue still reproduced.  
 
Regards, 
Bharathiraja 



BK Bharathiraja K Syncfusion Team January 23, 2019 02:23 AM

Hi Neil Gupta, 
 
We regret for the inconvenience caused. Since we have planned Volume-4 SP1 service pack release on coming 4th   February and include all the fix in service pack, we will not release next weekly build which was planned to roll out 29th January. We appreciate your patience until then. 
 
Thanks, 
Bharathiraja. 



NG Neil Gupta February 5, 2019 10:01 AM

Hi,

I just downloaded the 16.4.0.52 nuget package, and the cropping issue is still there. Was the fix supposed to be in this release?

Thanks,
Neil


DR Dhanasekar R Syncfusion Team February 6, 2019 07:59 PM

Hi Neil Gupta, 
 
Due to technical difficulties, we were unable to include the fix in our SP1 release (16.4.0.52). But we have found workaround to resolve this issue in sample. We can resolve this issue in any one of the following ways. 
 
1.       Setting UseSafeArea to true in Content Page. Please refer following code snippet 
 
ios:Page.UseSafeArea="true"
xmlns:syncfusion="clr-namespace:Syncfusion.SfImageEditor.XForms;assembly=Syncfusion.SfImageEditor.XForms" 
 
       2.  Navigate the ImageEditor Content Page by PushAsync instead of PushModalAsync 
 
We have also modified the sample for above solution and please find the sample from below location. 
 
 
Regards, 
Dhanasekar 
 


Loader.
Live Chat Icon For mobile
Up arrow icon