We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Unable to get correct row count for Essential Grid

Thread ID:

Created:

Updated:

Platform:

Replies:

98138 Feb 8,2011 09:51 PM UTC Dec 12,2011 01:32 PM UTC WinForms 3
loading
Tags: Test Studio
Samip Patel
Asked On February 8, 2011 09:51 PM UTC

Hi,

Our product creates extra rows when it is low on available rows and a new entry is saved. Product only displays filled rows while hiding any extra empty rows.

So, for example, let us say, 20 rows are displayed in our product but there might be more 20 actual rows but empty rows are not visible to user.

I am trying to get current row count using QTP to find out last visible row (which is the row available for addition of new data) but always getting 0 as row count.

My code in QTP is:
MsgBox SwfWindow("Product").SwfObject("Grid").GetRowCount()

My configuration is:

QTP 11.00
Essential Studio 8.4.0.10
Syncfusion QTP add-in 8.4.0.10

Would appreciate if anybody can help me figure out how to get correct visible row count in this situation?




Jisha Joy [Syncfusion]
Replied On February 14, 2011 10:04 AM UTC

Hi Samip,

We are unable to see the issue mentioned. Could you please provide us a sample that shows the issue while testing?.

Regards,
Jisha


jitesh
Replied On December 5, 2011 11:54 AM UTC

Hi,

I am facing a similar issue wherein I am not able to perform any action on a grid.(eg GetCellData, RowCount etc)
Syncfusion version used be dev is v8.4.0.10.
My configuration is same:

QTP 11.00
Essential Studio 8.4.0.10
Syncfusion QTP add-in 8.4.0.10

I have made changes to Swfconfig.xml file as mentioned in help docs.



AUT
C:\Program Files\Syncfusion\Essential QTP\8.4.0.10\Bin\2.0\GridControl.dll
Syncfusion.TestStudio.Grid.GridControl




AUT
C:\Program Files\Syncfusion\Essential QTP\8.4.0.10\Bin\2.0\GridControl.dll
Syncfusion.TestStudio.Grid.GridControl




Could anyone please help on this?



Asarudheen S [Syncfusion]
Replied On December 12, 2011 01:32 PM UTC

Hi Hi Jjain,

Thanks for the update.

We could not able to reproduce the issue with your config.xml.
Could you please send us simple sample to show your issue so that we could look into the issue and provide you a better and exact solution?

Appreciate any additional information.

Regards,
Asarudheen.


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;