We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Diagram Builder Sample problem

I cannot get the Diagram Builder Sample to work correctly with image symbols. Here is what I am doing: 1) Using the Symbol Designer I create a Palette with a single image symbol. I am using a 7KB GIF file. I also associate both the small and large icons with this .gif image. 2) Using the Diagram Builder Sample I add the palette created in step 1 to the toolbar. The image appears fine within the added palette. I create a new diagram. I then attempt to drag and drop the image symbol onto the new diagram. The Diagram Builder Sample hesitates for a moment and then draws the diagram with just the grid lines, my image does not appear. If I attempt to do anything from that point (like resize the window) the Diagram Builder Sample crashes with a stack overflow exception. This appears to be a bug, any fix in the near future? Thanks - Roland Martin

1 Reply

AD Administrator Syncfusion Team December 22, 2003 06:39 AM

Thank you for pointing out this problem. It has been corrected and the fix will show up in the next beta release. >I cannot get the Diagram Builder Sample to work correctly with image symbols. Here is what I am doing: > >1) Using the Symbol Designer I create a Palette with a single image symbol. I am using a 7KB GIF file. I also associate both the small and large icons with this .gif image. > >2) Using the Diagram Builder Sample I add the palette created in step 1 to the toolbar. The image appears fine within the added palette. I create a new diagram. I then attempt to drag and drop the image symbol onto the new diagram. The Diagram Builder Sample hesitates for a moment and then draws the diagram with just the grid lines, my image does not appear. If I attempt to do anything from that point (like resize the window) the Diagram Builder Sample crashes with a stack overflow exception. > >This appears to be a bug, any fix in the near future? > >Thanks - Roland Martin

Loader.
Live Chat Icon For mobile
Up arrow icon