We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Hidden rows problem

Thread ID:

Created:

Updated:

Platform:

Replies:

79260 Jan 27,2009 07:03 AM Jan 30,2009 05:30 AM Windows Forms 3
loading
Tags: GridControl
Administrator [Syncfusion]
Asked On January 27, 2009 07:03 AM

Hi.
I'm using a GridControl to show some data. And I'm using GridControl's HideRows property to show or hide some rows depending on the details the user wants.

The problem is that sometimes the rows that are not hidden are not drawn in the grid.

I can't find the logic why or when that happens.

Is there a way to find out which rows in the grid will be drawn, because the HideRows property apparently isn't the only constraint.

If you need any additional information, please ask :)

Thank you!


Nisha Arockiya A [Syncfusion]
Replied On January 28, 2009 07:59 AM

Hi Zvonko,

Thanks for your interest in Syncfusion Products.

I am afraid that I could not able to reproduce the issue of Hidden rows problem as you mentioned above. Could you please provide an issue reproduced sample or the reproducing steps so that we can sort out the problem and direct you to the exact solution on time??

Sample:
http://websamples.syncfusion.com//samples/Grid.Windows/Development/GC_HideRows_F79260.zip

Please let me know if this helps and provide more information on this issue.

Regards,
Nisha.


Administrator [Syncfusion]
Replied On January 29, 2009 10:08 AM

I think I found the solution and maybe the problem :)

If there was a change in some other sections in the program, the grid would clear and enter new data in it. The problem is (I think) that I used 'grid.RowCount = 0;' statement to clear the table. But the properties HideRows[] would in some cases persist in the grid. So new data would be hidden at those positions. I think.

The solution that I used is setting HideRows[] property on all rows to 'false' before clearing the table.

Best regards


Nisha Arockiya A [Syncfusion]
Replied On January 30, 2009 05:30 AM

Hi Zvonko,

Glad to know that you have solved the problem by yourself. Thanks for sharing information with us. Please let us know any other concerns.

Regards,
Nisha.


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;