We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

to disable click event for parent items in menu object

Thread ID:

Created:

Updated:

Platform:

Replies:

79127 Jan 22,2009 02:16 AM UTC Jan 24,2009 07:12 AM UTC ASP.NET Web Forms (Classic) 1
loading
Tags: Tools
Administrator [Syncfusion]
Asked On January 22, 2009 02:16 AM UTC

Hi,

I am trying the menu object with MenuItemBinding.I like binding ID and Parent ID fields for hierarchical data.

But is it possible to disable all events for parent items when using menu DataBindings.

what i want is, just the ultimate nodes should be clickable and the link cursor should appear just these ultimate nodes.

I am attaching the representative sample image.



trial_syncfusion_menu_bb318e9e.zip

Rekha P [Syncfusion]
Replied On January 24, 2009 07:12 AM UTC

Hi Sinan,

Thank you for your interest in Syncfusion Products.

Yes, the disable of NavigateUrl for Menu parent items is possible by enabling NavigateUrl for parent items as null in ItemSelect event. Please refer the code snippet below to achieve this.

bool Menu1_ItemSelect(object oSender, Syncfusion.Web.UI.WebControls.Tools.MenuCommandEventArgs e)
{
if (e.Item.HasSubNodes) //Parent Item
{
e.Item.NavigateUrl = "";
}
return true;
}


Also please refer the sample below which illustrates the NavigateUrl to only child items in Menu.

http://websamples.syncfusion.com/samples/Tools.Web/7.1.0.21/F79127_Menu/main.htm

We appreciate your patience and please let me know if this helps you.

Thanks,
Rekha


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;