We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Chart and legend didn''t show up

Thread ID:





78525 Dec 17,2008 07:38 AM UTC Mar 27,2009 12:12 PM UTC ASP.NET Web Forms (Classic) 9
Tags: Chart
Administrator [Syncfusion]
Asked On December 17, 2008 07:38 AM UTC

Dear All,

After my chart's page is published the chart and legend is showing strange behavior, sometime it show up and sometime it didn't.this is only happens when i using "handler" as the "outputformat" but anytime i using the "diskfile" the picture is drawn/shown perfectly.

i've attached the screen capture for this issue.




Manohari [Syncfusion]
Replied On December 17, 2008 01:45 PM UTC

Hi Irman,

Thanks for the screenshot. I am afraid that I am not able to reproduce the issue. I have tested for this issue by deploying the sample in server and the chart is rendered properly.

Please refer to the sample used for testing this issue in this link below.


If you are still able to reproduce this issue, Is it possible for you to provide us with the simplified sample that could reproduce this issue from your end. So that it would be more helpful for us to analyze and provide you with the better solution at the earliest.

Please let me know if you need any other information. Thanks for your patience.


Peter Kovacs
Replied On March 24, 2009 10:11 AM UTC

Hi guys,

I have the same problem with the ASP.NET chart control. When debugging set to true in the web.config in a normal ASP.NET application, the chart is rendered as an empty picture (all white), but toolbar, context menu, exporting, printing, etc. still works, and exported picture looks correct. When debugging is false, it is rendered correctly.

However, I use the new MVC framework to create a web application, and the problem is the chart is ALWAYS rendered an empty picture in any of the views, but works the way I described earlier (context menu etc.). Setting the debug parameter, or any properties don't help either.

You can verify these issues easily, just add a chart to empty ASP.NET web application, and ASP.NET MVC web application projects, and these issues will show up, when you start debugging.

I use Syncfusion Essential Studio 2009 vol. 1 ( evaluation version.

Thanks for any help you can give me.


Administrator [Syncfusion]
Replied On March 24, 2009 11:20 AM UTC

I just tried asp.net's image control, and it has the same issues, so this is probably not a bug in Syncfusion chart, but a more general issue.

Manimala S [Syncfusion]
Replied On March 24, 2009 01:00 PM UTC

Hi Peter,

If the chart control alone is not shown, then the problem might be with the assembly references. In the web.config file just remove all the version attribute of the syncfusion assemblies. This will render the chart correctly.

Kindly, let me know if it works.


Peter Kovacs
Replied On March 25, 2009 12:05 PM UTC


if there was a problem with the references, it would generate a compile time error I think. I tried deleting the version attribs, but that didn't help. But as I wrote, other image based controls have the same problem, so I think this is some kind of general issue, not syncfusion chart based.

Thanks for the help.


Manimala S [Syncfusion]
Replied On March 26, 2009 01:31 PM UTC

Hi Peter,

Thanks for using Syncfusion Products.


Peter Kovacs
Replied On March 27, 2009 11:50 AM UTC


one of my co-workers found out what is the problem. Microsoft MVC framework makes extensive use of routing, meaning that the urls don't represent actual path on the server. You must add
line to MvcApplication class's method RegisterRoutes in Global.asax. This way the httphandler of the chart image won't get routed, and will be displayed.


Peter Kovacs
Replied On March 27, 2009 11:52 AM UTC

And by MvcApplication class I mean the System.Web.HttpApplication derived class that represents your web application.

Manimala S [Syncfusion]
Replied On March 27, 2009 12:12 PM UTC

Hi Peter,

That would be great. Thanks for the update.



This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon