We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Vectorial Node from WMF file

Thread ID:

Created:

Updated:

Platform:

Replies:

74011 May 28,2008 01:08 PM UTC Jul 4,2008 12:47 PM UTC WinForms 12
loading
Tags: Diagram
Adrien Geymond
Asked On May 28, 2008 01:08 PM UTC

We expect for a vectorial quality for those node. Even, if the user resizes the node we expect a high level of quality for the pictures.

We use image file as node :
new MetafileNode(dir+"\\E273.wmf");

Nevertheless, even if we use wmf files (vectorial format) for nodes, we lose the quality of the picture when the node is loaded in the diagram. For instance, if we open the image in Visio there is a significant difference.

Is there a way to improve the quality of nodes:
1/ use of another node objects
2/ parameters on the Metafile Node
3/ parameters on the Diagram, the view ...

In the attached sample, you will find a quick demo that allow the user to drag and drop a node on the diagram.
you will be able to see the difference between the node and the original picture.

I hope that there is a way to improve my demo.

Do not hesitate to contact me if you need further details.

Thank you by advance for your help.

Adrien


J.Nagarajan [Syncfusion]
Replied On May 30, 2008 08:57 AM UTC

Hi Geymond ,

Thanks for your interest in Syncfusion products.

We could not find your attachment in the previous post. Could you please attach you demo and it will help us to resolve it as early as possible.

Thanks,
Nagaraj



Adrien Geymond
Replied On June 2, 2008 06:57 AM UTC

please find attached the sample demo.

Adrien



ResiSpecSymbol_850ff651.zip

J.Nagarajan [Syncfusion]
Replied On June 2, 2008 12:28 PM UTC

Hi Adrien ,

We regret for the inconvenience caused. I have tested this issue in v5.1.0.51 and we could not see the difference in quality of the image in Diagram and the original picture. Please refer to the attached screen shot that shows my test result.

http://websamples.syncfusion.com/ScreenShots/Screenshots_46784.zip

Could you please provide us a screen shot or video file to see this issue.

Thanks ,
Nagaraj


Adrien Geymond
Replied On June 5, 2008 08:42 AM UTC

Hello,

Thank you for your answer. Actually the problem is that when you open a WMF file with the default viewer of windows the quality is not vectorial.

As you will see in the attached bitmap there is a significative difference when i open the same file with Visio (that manages vectorial format) and using my demo : for instance you can have a look on borders and lines.

So i would like to know if there is a way to to improve the quality of vectorial format in my demo ?

Thank you by advanced for your help.

Adrien




SymbolDifference_ac4c9217.zip

J.Nagarajan [Syncfusion]
Replied On June 6, 2008 01:37 PM UTC

Hi Adrian ,

I was able to see the difference between the rendering of vectorial formatted image in visio and in diagram. Currently the diagram does not manages the vectorial format. I have logged a defect report in this regard and forwarded this issue to our developers. I will get back to you with more details regarding the status of this issue on or before 10th June 2008.

Thanks for your patience.

Regards,
Nagaraj


Adrien Geymond
Replied On June 6, 2008 04:54 PM UTC

Thank you for your answer. I wait for news from you about this issue.

I hope that you will be able to help us because we need this feature for a strategic project.

Thank you by advance for your help.

Kind regards,

Adrien




J.Nagarajan [Syncfusion]
Replied On June 10, 2008 12:14 PM UTC

Hi Adrian ,

I regret for this long delay in getting this issue solved. Our developers are currently working on this issue. e been repeatedly encountered with some issues that makes this delay in getting this issue resolved. We will try to fix the issues at the earliest possible for sure and I will get back to you with more details regarding the status of this issue on or before 12th June 2008.

Thanks,
Nagaraj


Adrien Geymond
Replied On June 12, 2008 08:09 AM UTC

Thank you for your answer. I am confident that your development team will fix the issue.

I will wait from news from you.

Adrien


J.Nagarajan [Syncfusion]
Replied On June 12, 2008 09:05 AM UTC

Hi Adrian ,

I have consulted with our developers and they are currently working on this issue with high priority. We will fix this issue and the fix will be available on or before July 3. I will get back to you with more details regarding this issue on July 3.

Thanks for your patience.

Regards,
Nagaraj


Adrien Geymond
Replied On June 17, 2008 12:41 PM UTC

Ok, Thank you for your answer.

I am waiting from news from you regarding this issue.

Adrien


Adrien Geymond
Replied On July 4, 2008 08:37 AM UTC

Hello,

Can yoy provide me some information regarding the fix.
Indeed, base on your post i understood that the fix should be available.

I am waiting from news.

Thank you


J.Nagarajan [Syncfusion]
Replied On July 4, 2008 12:47 PM UTC

Hi Adrien,

I regret for this long delay in getting this issue solved. Currently we are busy with our release work and our developer have been repeatedly encountered with some issues that makes this delay in getting this issue resolved. We will try to fix the issues at the earliest possible for sure. We assure you that this issue have been continously monitored in our support status with high priority.

Thanks ,
Nagaraj



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

or the page will be automatically redirected to sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;