We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Sorting Issue on GridDataBoundGrid

Thread ID:

Created:

Updated:

Platform:

Replies:

67135 Aug 9,2007 10:31 AM UTC Aug 9,2007 09:30 PM UTC WinForms 1
loading
Tags: GridControl
Anand
Asked On August 9, 2007 10:31 AM UTC

Hi,
We are using the GridDataBoundGrid. We have total of 3 grids on the screen and the lower LHS grid need the columns to be sorted. But the columns are not getting sorted whenever we click on the column headers. In QueryCellInfo of this grid I had made the cell as readonly and disabled by using the properties e.style.Enabled = False and e.style.ReadOnly = true. The SortBehaviour property of this grid is set to SingleClick.

Even after making the cells enabled and setting the readonly property to false (e.style.Enabled = True and e.style.ReadOnly = False), sorting on columns is not working. Could you please help me out. Many Thanks.



Sorting Issue.zip

haneefm [Syncfusion]
Replied On August 9, 2007 09:30 PM UTC

Hi Anand,

We tried to reproduce this issue in v5.1, but could not get this issue. Maybe I am not following the steps that you are doing. Attached sample working fine here. Can you post a small sample showing this problem or tell us how to see it in the Attached sample?

Here is a sample.
GDBGSortColumnHeader.zip

Best regards,
Haneef

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

or the page will be automatically redirected to sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;