We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Edit Mode GGC

Thread ID:

Created:

Updated:

Platform:

Replies:

62612 Jun 19,2007 08:14 AM Jun 20,2007 05:29 PM Windows Forms 3
loading
Tags: GridControl
Chris
Asked On June 19, 2007 08:14 AM

Hi,

currently a grid cell changes to the edit mode if a user clicks in a cell with a mouse click. Now i want to change this behavior. I want to select the cell when the user clicks on it with the mouse and switch to the edit mode if a user presses a key on the keyboard. Is this possible?

Cheers,
Chris

haneefm [Syncfusion]
Replied On June 19, 2007 11:02 AM

Hi Chris,

You can try setting the property ActivateCurrentCellBehavior to None.

[c#]
gridGroupingControl1.TableModel.Options.ActivateCurrentCellBehavior = GridCellActivateAction.None;

This None setting means that clicking on a cell does not activate it. You can activate the cell by pressing any one of the key.

Best regards,
Haneef

Chris
Replied On June 20, 2007 03:26 AM

Hi Haneef,

this works fine for the default cell types. I have a custom cell renderer and model inherited from GridComboboxCellRenderer / Model.

The problem here is that even if I set the GridCellActivateAction to "None" the DropDownPart shows up when I click on that cell. How can I get the same behavior for this cell types?

haneefm [Syncfusion]
Replied On June 20, 2007 05:29 PM

Hi Chris,

You need to set the SupportsFocusControl property in your custom cell renderer (which is derived from GridComboBoxCellRender) class. Below is a code snippet

this.SupportsFocusControl = true;

Best regards,
Haneef

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;