We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

GroupCaptionCell

Thread ID:

Created:

Updated:

Platform:

Replies:

60245 May 1,2007 02:35 PM UTC May 1,2007 09:09 PM UTC WinForms 4
loading
Tags: GridControl
Andy
Asked On May 1, 2007 02:35 PM UTC

Syncfusion 4.4
Visual Studio 2005

Trying to set the groupcaptioncell style with the following code in the QueryCellStyleInfo event:

if (e.TableCellIdentity.TableCellType == GridTableCellType.GroupCaptionCell)
{
e.Style.Borders.All = GridBorder.Empty;
e.Style.CellAppearance = GridCellAppearance.Flat;
e.Style.BackColor = Color.LightGray;
e.Style.Font.Bold = true;
}

But the groupcaptioncell does not set the color and the cell appreaence is not flat. Appreciate your help.
Thanks

haneefm [Syncfusion]
Replied On May 1, 2007 05:30 PM UTC

Hi Shek,

Try setting the Themed property of GroupCaptionCell to false. Here is a code snippet.

gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.Themed = false;
gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.Borders.All = GridBorder.Empty;
gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.CellAppearance = GridCellAppearance.Flat;
gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.BackColor = Color.LightGray;
gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.Font.Bold = true;

Best regards,
Haneef

Andy
Replied On May 1, 2007 07:04 PM UTC

Thanks Haneef. Now the backcolor is being set but the cell appearence is still not flat.

>Hi Shek,

Try setting the Themed property of GroupCaptionCell to false. Here is a code snippet.

gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.Themed = false;
gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.Borders.All = GridBorder.Empty;
gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.CellAppearance = GridCellAppearance.Flat;
gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.BackColor = Color.LightGray;
gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.Font.Bold = true;

Best regards,
Haneef

haneefm [Syncfusion]
Replied On May 1, 2007 08:51 PM UTC

Hi Shek,

Try setting the GroupCaptionCell's CellType as Static and let me know if this helps.

gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.CellType = "Static";

Best regards,
Haneef

Andy
Replied On May 1, 2007 09:09 PM UTC

Thanks Haneef. Looks fine now.

>Hi Shek,

Try setting the GroupCaptionCell's CellType as Static and let me know if this helps.

gridGroupingControl1.TableDescriptor.Appearance.GroupCaptionCell.CellType = "Static";

Best regards,
Haneef

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;