We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

The Maximun Y value and label don''t display wholly

Thread ID:

Created:

Updated:

Platform:

Replies:

57991 Mar 15,2007 01:16 PM UTC Mar 15,2007 09:31 PM UTC WinForms 1
loading
Tags: Chart
Administrator [Syncfusion]
Asked On March 15, 2007 01:16 PM UTC

Hi,
V4.4.0.51 & VS2003

I set up Yaxes from 0 to 10. The chart cut off the point with value 10 on the top, besides the "10" Yaxes label does not display. How to display them wholly? It looks like need some PADDING SPACE for the YAxes.

//code for setting the YAxes range
TargetChart.PrimaryYAxis.RangeType = ChartAxisRangeType.Set;
TargetChart.PrimaryYAxis.Range.Min = 0;
TargetChart.PrimaryYAxis.Range.Max=10;
TargetChart.PrimaryYAxis.Range.Interval=1;


Thanks,

Lan

screen_Y_Cutoff.zip

Administrator [Syncfusion]
Replied On March 15, 2007 09:31 PM UTC

Hi Lan,

Thank you for using Syncfusion products.

You can create the padding space for Y-axis by using Offset property. Please refer to the following code snippet.

[ C#]

//code for setting the YAxes range
TargetChart.PrimaryYAxis.RangeType = ChartAxisRangeType.Set;
TargetChart.PrimaryYAxis.Range.Min = -1;
TargetChart.PrimaryYAxis.Range.Max = 10;
TargetChart.PrimaryYAxis.Range.Interval = 1;

//A padding space create on top of Y-axis
TargetChart.PrimaryYAxis.Offset = -1;

I have change the minimum value of Y-axis depends on our Offset value. Please let me know if you have any queries.

Regards,
Rajesh

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;