We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

GDBG Horizontal scroll bar broken

Thread ID:

Created:

Updated:

Platform:

Replies:

54561 Jan 11,2007 11:59 AM UTC Jan 12,2007 04:21 AM UTC WinForms 3
loading
Tags: GridControl
James Mulvey
Asked On January 11, 2007 11:59 AM UTC

I have a GDBG; it correctly displays a vertical scroll bar when needed but not a horizontal scrollbar.

I can set it so the horizontal scrollbar is always visible - but I don't want that - just want it do display when needed.

Seems like a pretty basic requirement...

Using: 4.2.0.37

Administrator [Syncfusion]
Replied On January 11, 2007 12:07 PM UTC

Hi Mulveyja,

Try setting the HScrollBehavior property to GridScrollbarMode.Enabled.

this.grid.HScroll = true;
this.grid.HScrollBehavior = GridScrollbarMode.Enabled;

Let me know if this helps.

Best Regards,
Haneef

James Mulvey
Replied On January 11, 2007 12:30 PM UTC

That's not really a proper solution is it?

1) It doesn't hide the scroll bar when not required.
2) The scrollbar doesn't seem to operate properly (it enables only after the second to last column is clipped and doesn't scroll to the end of the last column properly).


Administrator [Syncfusion]
Replied On January 12, 2007 04:21 AM UTC

Hi Mulveyja,

1) It doesn't hide the scroll bar when not required.
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
You can specify the horizontal scrollbar setting of the grid control with HScrollBehavior. You can combine the various options GridScrollbarMode enumeration. Here is a the detail of the GridScrollBarMode enum.

GridScrollbarMode.DetectIfShared :
Initial setting. Detect parent view if it has shared scrollbars.

GridScrollbarMode.Disabled :
Disable scrollbars.

GridScrollbarMode.Enabled:
Always show scrollbars.

GridScrollbarMode.Automatic :
Show scrollbars only when neccessary.

GridScrollbarMode.Shared :
Scrollbars are shared with a parent control.

GridScrollbarMode.AutoScroll :
When you resize cells in the grid or when you resize the grid window automatically and you are at the last row or column of the grid, automatically scroll the grid so that whitespace below or right of the grid is minimal. Starting with version 3.2.1.1 this is now the default behavior. You need to explicitly DisableAutoScroll to disable AutoScroll.

GridScrollbarMode.DisableAutoScroll :
When you resize cells in the grid or when you resize the grid window automatically and you are at the last row or column of the grid, disable automatically scrolling the grid.

Try this code :
this.gridControl1.HScroll = true;
this.gridControl1.HScrollBehavior = GridScrollbarMode.Automatic ;

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

2) The scrollbar doesn't seem to operate properly (it enables only after the second to last column is clipped and doesn't scroll to the end of the last column properly).
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Try enabling the pixel scrolling property of the grid.
this.gridControl1.HScrollPixel = true;
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Best Regards,
Haneef

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;