We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

checkbox tristate

Thread ID:

Created:

Updated:

Platform:

Replies:

523 Jul 3,2002 04:07 AM Jan 17,2004 11:53 PM Windows Forms 3
loading
Tags: FAQ
Administrator [Syncfusion]
Asked On July 3, 2002 04:07 AM

I have to click checkbox twice to make it checked/unchecked.It shows me a tristate in b/w. Please tell me how to avoid it.

Clay Burch [Syncfusion]
Replied On July 3, 2002 01:27 PM

> I have to click checkbox twice to make it checked/unchecked.It shows me a tristate in b/w. > Please tell me how to avoid it. > You need to: 1) add a TableStyle to your datagrid. 2) for each column add a columnstyle to this tablestyle 3) for the bool column, make sure to add a DataGridBoolColumn and set its AllowNull property to false. You can do this entirely from the designer, or entirely from code. For a code sample, check this FAQ: How can I put a checkbox in a column of my DataGrid? Check it out at: http://www.syncfusion.com/faq/winforms/search/754.asp

Administrator [Syncfusion]
Replied On July 4, 2002 12:53 AM

> > I have to click checkbox twice to make it checked/unchecked.It shows me a tristate in b/w. > > Please tell me how to avoid it. > > > > You need to: > 1) add a TableStyle to your datagrid. > 2) for each column add a columnstyle to this tablestyle > 3) for the bool column, make sure to add a DataGridBoolColumn and set its AllowNull property to false. > > You can do this entirely from the designer, or entirely from code. For a code sample, check this FAQ: > How can I put a checkbox in a column of my DataGrid? > > Check it out at: > http://www.syncfusion.com/faq/winforms/search/754.asp > thanx

kamal
Replied On January 17, 2004 11:53 PM

i have a similar problem when i add a new row to the grid the bool column appears in tristate b/w i have already set the allownulls to false rgds kamal > > I have to click checkbox twice to make it checked/unchecked.It shows me a tristate in b/w. > > Please tell me how to avoid it. > > > > You need to: > 1) add a TableStyle to your datagrid. > 2) for each column add a columnstyle to this tablestyle > 3) for the bool column, make sure to add a DataGridBoolColumn and set its AllowNull property to false. > > You can do this entirely from the designer, or entirely from code. For a code sample, check this FAQ: > How can I put a checkbox in a column of my DataGrid? > > Check it out at: > http://www.syncfusion.com/faq/winforms/search/754.asp >

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;