We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Grid columns

Thread ID:

Created:

Updated:

Platform:

Replies:

50767 Oct 18,2006 12:11 PM Nov 14,2008 01:33 AM ASP.NET Web Forms (Classic) 4
loading
Tags: GridGroupingControl
Michael Digman
Asked On October 18, 2006 12:11 PM

I want to fix the column headers to the top of the control. I have currently fixed the size of the control and when there is no data, the columns are displayed at the bottom of the control. Also when you scroll I want to always see the column headers, at the moment when you scroll down the columns get hidden.

Can you please tell me how to do this.

Cheers,

Michael

Administrator [Syncfusion]
Replied On October 18, 2006 04:06 PM

Hi Michael,

You can set the ForzenRows property of our grid accordingly and avoid hiding the headers when scrolling. When setting the Frozen rows only the other rows will be scrolled.

To apply Frozen rows through code

this.GridGroupingControl1.FrozenRows=3;

Please have a look at our Grid.grouping.web->Scrolling and Sizing->GridWidth and Sizing Sample in our online sample where you can set the Frozen rows and can get more details.

Let us know if you need more info.

Thanks,
A.Sivakumar

John Hudai Godel
Replied On November 11, 2008 07:24 PM

We are eveluating your essential grid and am testing it's frozen column/row feature with 200 rows and 15 columns. When I freeze a column grid having very bad performance to scroll horizantally (also some vertically).

Is this a known issue?

Please let me know.

Sincerely
John H. Godel


>Hi Michael,

You can set the ForzenRows property of our grid accordingly and avoid hiding the headers when scrolling. When setting the Frozen rows only the other rows will be scrolled.

To apply Frozen rows through code

this.GridGroupingControl1.FrozenRows=3;

Please have a look at our Grid.grouping.web->Scrolling and Sizing->GridWidth and Sizing Sample in our online sample where you can set the Frozen rows and can get more details.

Let us know if you need more info.

Thanks,
A.Sivakumar


James Hargis
Replied On November 13, 2008 11:36 AM

This is absolutely a known issue with scrolling and IE 7. They issued a patch today, and I've applied it, but I still don't see an improvement in performance at all. Have you tried the Nov.13 patch? And did it improve performance for you? We're desperately searching for answers.

Thanks,
James

>We are eveluating your essential grid and am testing it's frozen column/row feature with 200 rows and 15 columns. When I freeze a column grid having very bad performance to scroll horizantally (also some vertically).

Is this a known issue?

Please let me know.

Sincerely
John H. Godel


>Hi Michael,

You can set the ForzenRows property of our grid accordingly and avoid hiding the headers when scrolling. When setting the Frozen rows only the other rows will be scrolled.

To apply Frozen rows through code

this.GridGroupingControl1.FrozenRows=3;

Please have a look at our Grid.grouping.web->Scrolling and Sizing->GridWidth and Sizing Sample in our online sample where you can set the Frozen rows and can get more details.

Let us know if you need more info.

Thanks,
A.Sivakumar




Rajarajeswari S [Syncfusion]
Replied On November 14, 2008 01:33 AM

Hi James,

Thanks for using Syncfusion products.

Please refer the sample from the below link, with patch assemblies:

http://websamples.syncfusion.com/samples/Grid.Web/6.4.0.15/Grid_Web_TableScroller/main.htm

Please check the above sample, it is clearly illustrating you that the TableScroller issue with IE 7.0 has been fixed with the patch given to you on Nov 13th.


Regards,
Raji


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;