We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Pasting from Excel into covered cells

Thread ID:

Created:

Updated:

Platform:

Replies:

48773 Sep 4,2006 03:34 PM UTC Sep 6,2006 09:34 AM UTC Windows Forms 3
loading
Tags: GridControl
Sara Dickinson
Asked On September 4, 2006 03:34 PM UTC

Hi,

I have a grid with a row containing columns with covered cells (3 per column). When I try to paste multiple (e.g. 3) cells from Excel into that row, only the first column is updated. From debugging I can see that GridControl.OnPasteCellText is called 3 times for columns 1,2 and 3 because there are 3 pieces of data to paste. But because the cells are covered the data should be pasted into columns 1,4 and 7. Have a missed setting a flag on the table or do I need to write a custom paste method to do what I want?

Administrator [Syncfusion]
Replied On September 5, 2006 01:46 AM UTC

Hi,

We are currently looking into this issue and will update you the details.

Thanks for your patience.
Best Regards,
Megavannan

Administrator [Syncfusion]
Replied On September 6, 2006 08:40 AM UTC

Hi Sara,

The Attached sample demonstrates the covered cell custom pasting in a grid. It implements the ClipboardPaste event to manually assign the cell value in a grid.

Here is a sample.
http://www.syncfusion.com/Support/user/uploads/CopyPaste_4bb54183.zip

Let me know if you are looking something different.

Best Regards,
Haneef

Sara Dickinson
Replied On September 6, 2006 09:34 AM UTC

Hi Haneef,

I was afraid this was the answer.... thanks. Sara.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;