We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

sorting saves value in wrong place

Thread ID:

Created:

Updated:

Platform:

Replies:

48545 Aug 30,2006 09:14 AM Aug 31,2006 09:35 AM Windows Forms 2
loading
Tags: GridControl
Irina Jouk
Asked On August 30, 2006 09:14 AM

Hi,
I use Grid Grouping Control. I first click on any column header to sort. Then enter value for row#1, column #2. Then click on any empty column. The value will moved to the another row that has #1 before sorting.
For example:
Original rows:
A
B
C
Rows after sorting:
C
B
A
Enter word ‘test’ for C:
C test
B
A
Click on any empty row and get:
C
B
A test

Is there a way to fix it. If I cannot fix it, how to disable sorting?

Thanks in advance
Irina

Administrator [Syncfusion]
Replied On August 31, 2006 01:33 AM

Hi Irina,

This is an expected behavior. There is no built-in support for disabling the sort order in Essential version 2.0.5.1. As a workaround, you can disable the sorting using TablecontrolCellClick event. Please refer the below forum thread for more details.

http://www.syncfusion.com/Support/Forums/message.aspx?MessageID=41491

Thanks,
Haneef

Irina Jouk
Replied On August 31, 2006 09:35 AM

Thanks Haneef. It works

Irina

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;