We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

weird problem...please help

Thread ID:

Created:

Updated:

Platform:

Replies:

36420 Oct 28,2005 07:22 PM Oct 28,2005 07:37 PM Windows Forms 2
loading
Tags: Tools
James Donnelly
Asked On October 28, 2005 07:22 PM

I''m experiencing a very strange problem. One of my users suddenly became unable to navigate our web forms application with the TabControlExt. It only happens for him. When he tabs from one tabpageext to the next tabpageext, it comes up blank. This happens when the user is using remote desktop via Terminal Server. So I logged in as this user, and ran the development environment in debug with his user name and password. Everything worked fine. Then, I went through Terminal Server and ran the application. I get the same problem...nothing when I change tabs. Luckily, I have a few tabs that still use only the SelectionChanged, rather than the SelectionChanging, event for navigation. So I tested these tabs and they work fine without a problem. So, here is my question: Is there any possible chance or reason that, for a specific user, an older Syncfusion library is being used for the application? We upgraded awhile back to the latest version 2 (.whatever) with the SelectionChanging event. The only explanation I can think of for this error is that the application is breaking and erroring out on the SelectionChanging event, and because it''s somehow or someway utilizing the older assemblies rather than the upgraded ones. It''s very strange, because this only just started happening for this user in the past few days. A few days ago, I moved the executable files up a directory when disabling the application (so noone could use it). This particular user tried to get in, and his shorcut automatically changed to the parent directory where I''d hidden the files. I didn''t find out for a few days. Is there any reason why, in the new location, the executable files somehow decided to stop using the Syncfusion DLLs in the directory normally referenced and instead starting using the GAC? If so, and the old version is still in the GAC, would this explain the weird behavior. Forgive my ignorance, but I''m not very clear and definitely wary of messing with the Syncfusion installation from past experience. I do believe, however, that the old assemblies are in the GAC on this Terminal Server, because my network guy didn''t want to mess with it, since the application would be referencing the assemblies in the overall application directory anyway. How can fix the user profile for this particular user so it doesn''t use the GAC anymore? Sorry for such a long message...I actually figured out my problem as I was typing halfway through. Now, I just need to figure out how to fix it. It must be a user-specific setting or configuration related to the application that instructs whether to use the local assemblies or those in the GAC. James

James Donnelly
Replied On October 28, 2005 07:34 PM

To make a long story short, I think the application is now referencing the GAC rather than the local assemblies for just a single user. If this is actually the case, and even possible, how would I fix this so that this user references the local assemblies again? Basically, the older version without the SelectionChanging event is in the GAC, and the newer version is being referenced locally by the application. When the user tried to open the application from a shortcut, when I had moved it during maintenance, Windows did its automatic search for the application exe and found it one directory up. Then, when it executed, that is likely when it couldn''t find the local Syncfusion assemblies and looked to the GAC. How do I switch it back for this user profile?

James Donnelly
Replied On October 28, 2005 07:37 PM

As a reminder, every other user does not have this issue or problem, and none of them tried to access the application while it was moved either.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;