We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Installing trouble with assembly manager

I am running VS 2003 version 7.1.3088 with microsoft .net framework 1.1 version 1.1.4322. I have tried installing 3.2.1.0 on my computer three time now and I recive this error message each time. This occurs during the assemby management installation part at the very end of installing. "an error occured updating at least one syncfusion assembly. Please close any process that maybe using the assembly and run again. " It also notes that a error log file has been created which is showen below. +++++++++++++++++++++++++++++++++++++++++++++++ System.NullReferenceException: Object reference not set to an instance of an object. at SFAssemblyManager.SwapUtilityDlg.On_Ok(Object sender, EventArgs e) at SFAssemblyManager.SwapUtilityDlg.OnIdle(Object obj, EventArgs e) at System.Windows.Forms.ThreadContext.System.Windows.Forms.UnsafeNativeMethods+IMsoComponent.FDoIdle(Int32 grfidlef) at System.Windows.Forms.ComponentManager.System.Windows.Forms.UnsafeNativeMethods+IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData) at System.Windows.Forms.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context) at System.Windows.Forms.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context) at System.Windows.Forms.Application.RunDialog(Form form) at System.Windows.Forms.Form.ShowDialog(IWin32Window owner) at System.Windows.Forms.Form.ShowDialog() at SFAssemblyManager.SwapUtilityDlg.Main(String[] args) ++++++++++++++++++++++++++++++++++++++++++++++++ Does anyone know what might be going on with this issue. THANKS FOR YOUR TIME!

2 Replies

DS david skye duke July 15, 2005 12:19 PM

I looked farther into this issue and saw all the .dll files were placed into the Syncfusion\assemblies\1.0 folder and should have been placed into 1.1 folder. Are these 1.0 dll files or can I just move them over to the 1.1 folder and run them from there?


AD Administrator Syncfusion Team July 15, 2005 01:42 PM

Hi Skye, When the install is complete, have you tried to manually run the Assembly Manager through the start menu? If this proceeds without error, everything should be good to go. Otherwise, it is possible to mimic the behavior of the Assembly Manager yourself by: Copy the 1.1 folder under the Precompiled Assemblies folder (e.g. c:\program files\syncfusion\essential studio\3.3.0.0\precompiledassemblies\3.3.0.0\1.1) to the Assemblies folder under the install root (e.g. c:\program files\syncfusion\essential studio\assemblies\1.1). Then take the assemblies from the assemblies folder and add these to the GAC. The assemblies are version specific, and while you can use 1.0 assemblies in a 1.1 application, the 1.0 assemblies might bring in unwanted dependencies whereas the 1.1 version would not. Let us know if you continue to experience difficulties. Thanks, and have a great day! -Trampas

Loader.
Live Chat Icon For mobile
Up arrow icon