We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Not saving my grid properties in VS designer

I have a GridGroupingControl on a form. This is bound to a typed DataSet. However, I want to simply change the header text for each column (it defaults to the dataset''s column name). So in the property editor (while in design mode for the form)... I go down to TableDescriptor->Columns->Column_xxx->HeaderText and set the property. It seems to work while I am there.. however, nothing is actually added to the code and if I close the form and come back, nothing is changed. Why is it not saving my changes?

4 Replies

AD Administrator Syncfusion Team June 29, 2005 10:54 AM

What version are you using? I this both in 3.2.1.0 and a later in-house version and did not see the problem.


BW Brian Wright June 29, 2005 10:56 AM

3.2.1.0 as far as I know.. I installed the trial version about 35 days ago and recently reinstalled the product when we bought a copy.. I believe I have been seeing these types of problems since then.


AD Administrator Syncfusion Team June 29, 2005 11:26 AM

Here is the sample I tried. \Syncfusion\Essential Studio\3.2.1.0\Windows\Grid.Windows\Samples\Grouping\HierarchyView\VB I first changed a header text on one of the columns in the existing grid. That seemed to persist through quiting the program and reloading it. I then added a second GridGroupingCOntrol to the form and set its DataSource to be the Orders table. I was able to change the header text there as well. Does this fail for you? You can check the version by opening the references node in the solution explorer window, clicking a SYncfusion reference, and then looking in the property window.


BW Brian Wright June 29, 2005 02:08 PM

Okay my version is: 3.201.1.0 I completely uninstalled the grid, then reinstalled. Mine was still not saving. I then went into the same sample you cited (albeit the C# version) and I can edit those headertext properties and close the form and they are properly persisted... so I do not know why it is not working in my project. I lastly simply went in.. removed all Syncfusion references from my project and then re-added them and it seems to be working. Go figure.

Loader.
Live Chat Icon For mobile
Up arrow icon