We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

404 returned for syncfusion_chart_generate.ashx

I am trying to use a ChartWebControl and I am getting no output. I have set the OutputFormat = Handler property. It works fine in my development environment, but when I try to deploy the Syncfusion assemblies (listed below) to a production machine web app''s bin directory, and when I add the section to the app''s web.config file, I get a 404 error for syncfusion_chart_generate.ashx. Here are the Syncfusion assemblies in the app''s bin directory: Syncfusion.shared.base.dll Syncfusion.shared.windows.dll Syncfusion.shared.web.dll Syncfusion.core.dll Syncfusion.chart.base.dll Syncfusion.chart.windows.dll Syncfusion.chart.web.dll Syncfusion.grouping.base.dll Syncfusion.grouping.web.dll Here is the section from the web.config file: The app is set up for Windows authentication. The user that is testing the app is me, so I do have write access to the virtual directory. Any thoughts on what else I need to do to get this to work?

2 Replies

DJ Davis Jebaraj Syncfusion Team May 2, 2005 09:33 AM

Hi Pete, One thing I noticed in the web.config section you had pasted is the reference to the Syncfusion Essential Diagram web handler. Please try removing this line: Thanks, Davis


PM Peter Moss May 2, 2005 12:03 PM

Davis, Thanks for the response. Yes, I took that line out of web.config. It turns out I was also missing 1 of the assemblies from the list. So one of the 2 made things work. Thank you for your help, Pete

Loader.
Live Chat Icon For mobile
Up arrow icon