We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

hiding row headers in GridDataBoundGrid

Thread ID:

Created:

Updated:

Platform:

Replies:

28150 Apr 25,2005 09:08 PM UTC Apr 26,2005 01:12 PM UTC WinForms 2
loading
Tags: GridControl
Tyler
Asked On April 25, 2005 09:08 PM UTC

I''m using a version of the GridPrintToFitDocument to fit a GridDataBoundGrid onto a single width page (multiple pages long). Everything works great but now I want to remove the row headers to have more real estate on the page to work with. The documentation/samples/forum questions I''ve seen all seem to relate only to GridControl and not GridDataBoundGrid. I''ve tried: grid.Model.Properties.PrintRowHeader = false; and grid.Properties.PrintRowHeader = false; and setting the grid_QueryColWidth delegate and setting the 0 indexed colum to a width of 0. All of these work in the GridControl but don''t seem to have any affect on the GridDataBoundGrid control. I''ve attached the class that I''ve been modifying. -Tyler GridPrintToFitDocument_6614.zip

Administrator [Syncfusion]
Replied On April 26, 2005 01:33 AM UTC

One observation is that _grid.PrintingMode is not really being used here as you are actually drawing a bitmap and then pritnting the bitmap. So, instead of trying to use the PrintingMode together with QueryColWidth, add your own flag that you test in the QueryColWidth handler. Then set this flag at the top of your OnPrintPage override, and turn it off at the bottom. Then hopefully, this flag will work in QueryColWidth to allow teh header width to be set to zero.

Tyler
Replied On April 26, 2005 01:12 PM UTC

that makes sense and worked. thanks alot.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;