We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

GDBG, Filterbar, VScrollBehavior=Enabled

Hi, I have attached screenshots from the FilterBarGrid sample. I made the modification to set the VScrollBehavior and HScrollBehavior to Enabled. Screenshot 01: Scroll down to the middle of the grid, set the filter in the Country column to ''Germany'' Screenshot 02: After filtering, it seams that there is no result Screenshot 03: After scrolling up with the mouse wheel, the result is displaying GDBGScrollFilterbar03_6086.zip

3 Replies

AD Administrator Syncfusion Team April 22, 2005 04:43 AM

Hi Clay, I was to fast.... Is there a missing UpdateScrollBars call in the FilterBar? Regards, Thomas


AD Administrator Syncfusion Team April 22, 2005 05:44 AM

I think the visible disabled vscrollbar is preventing the grid from resetting its toprow at this point. We will dig into the code to see if there is something we can add to avoid this problem without impacting existing code. I was able to work around it by explicitly setting the toprow in the FilterBarTextChanged event. private void GridFilterBarTextChanged(object sender, GridFilterBarTextChangedEventArgs e) { this.label2.Text = theFilterBar.RowFilter; this.gridDataBoundGrid1.TopRowIndex = 1; }


AD Administrator Syncfusion Team April 22, 2005 10:02 AM

Thanks Clay

Loader.
Live Chat Icon For mobile
Up arrow icon