We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Manually scrolling.

Thread ID:

Created:

Updated:

Platform:

Replies:

26834 Apr 1,2005 09:41 AM UTC Apr 4,2005 07:45 PM UTC WinForms 6
loading
Tags: GridControl
Benny Hest
Asked On April 1, 2005 09:41 AM UTC

Hi. I''m having a little problem when I control horizontal scrolling the Essential Grid manually: myGridControl.HScrollBehavior = Syncfusion.Windows.Forms.Grid.GridScrollbarMode.Disabled; I have added buttons for scrolling up and down on a panel below the grid inside a panel control. This panel is visible only if there''s a need to display the buttons, and it''s visibility is controlled dynamically. Scrolling up and down is done by incrementing and decrementing the TopRowIndex property of the grid. The problem occurs when for instance the grid has more rows than the display area can display at once. Then my scrollbutton container panel is set visible (to enable scroll up) but it seems as if the grid control isn''t resized, because I can''t scroll down to display last rows. My panel is about two rows heigh, and excatly these two rows will never be visible. When I try to change TopRowIndex to see these last rows, it is ignored. Can you please give me a clue on what''s wrong? Best regards, Benny

Administrator [Syncfusion]
Replied On April 1, 2005 10:29 AM UTC

My guess is that this is a docking problem. Is the grid and the scroll panel docked in some way on the parent panel? If so, make sure you first put the scroll panel onto the parent panel and dock it Bottom. Then drop the grid on the parent panel, and dock it Fill. Be sure to remove the grid entirely from the form before you re-add it to the parent panel after adding teh scroll panel. The panel docking is applied in the order the controls are added to the panel. So, the general rule is that the control that is set dock=Fill must be the very last one added. Otherwise, it will think it has client area under some of the controls that were added later.

Benny Hest
Replied On April 4, 2005 11:10 AM UTC

I checked the InitializeComponents method of my user control. The grid control is added after the scrollbutton panel :( Any other suggestions? /Benny

Administrator [Syncfusion]
Replied On April 4, 2005 11:25 AM UTC

Tab orders may be playing a role. I would try completely removing the grid from the project leaving all other controls as you currently have them. Then drop a new grid back onto the panel and set it to dock.Fill. Unless you do this, I suspect some old tab setting or something serialized out in binary resources may still be affecting the Dock architecture. If you can upload a sample, we can try debugging it here.

Benny Hest
Replied On April 4, 2005 12:25 PM UTC

Tried that too. I''ve made a little zip package for you to test. I''d be thrilled if you can help me. ExtendedGrid_7845.zip /Benny

Administrator [Syncfusion]
Replied On April 4, 2005 06:28 PM UTC

Here is a try at getting this working. I adjusted the height of the OnLayout and did not try to rely on the docking to position it properly. http://www.syncfusion.com/Support/user/uploads/ExtendedGrid_88bfc524.zip

Benny Hest
Replied On April 4, 2005 07:45 PM UTC

Your solution solved my problem. Thanks a lot for your help! Regs, Benny

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;