We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

How to show decimal number in GDBG?

Decimal number from underlying table sometimes will be shown in the fomat like 4.77E-5 in GDBG. How can we set it to its original 0.0000477 ? Thanks.

1 Reply

AD Administrator Syncfusion Team March 18, 2005 01:54 AM UTC

Make sure you have set the GridBoundColumn.StyleInfo.CellValueType for the column to be a double type (or decimal or float type). You set this either in the grid.GridBoundColumns collection or the grid.Binder.InternalColumns depending upon whether you explicitly have added GridBoundColumns or not. Then you can set the GridBoundColumn.StyleInfo.Format to specify the format for the double column. You can try setting it to "F8" or "#.########" or or "0.0000####" some other format string.

Live Chat Icon For mobile
Up arrow icon