We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

License issue opening projects for older versions

Thread ID:

Created:

Updated:

Platform:

Replies:

25403 Feb 25,2005 11:15 AM Mar 21,2005 11:26 AM Windows Forms 5
loading
Tags: Tools
Administrator [Syncfusion]
Asked On February 25, 2005 11:15 AM

Hello, I am currently using 3.1.0.1 BETA. When opening a project for older version of Essential Tools I remove the old references and add the new ones and then ReBuild. I get this error when rebuilding: C:\dev\MDIForms_Docking_Sample\licenses.licx Could not transform licenses file ''licenses.licx'' into a binary resource. (1) : error LC0003 : Unabled to resolve type ''Syncfusion.Windows.Forms.Tools.DockingManager, Syncfusion.Tools, Version=2.0.1.0, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89'' When opening some other project the developement environment gets strange and keyboard, mouse not working as they should. I was previously using 3.0.1.0 but deleted it after installing 3.1.0.1 Beta, then I reinstalled 3.1.0.1 Beta. How is this solved? Thank you. Best regards, Böðvar

Administrator [Syncfusion]
Replied On February 25, 2005 12:03 PM

Hi, Licenses files are version specific. Every time I load an old project and get that message I do the following: 1) Open licenses.licx 2) Delete everything in the file 3) Recompile That should cause a new, valid licenses.licx to be generated. Regards, Gregory Austin Syncfusion Inc.

Administrator [Syncfusion]
Replied On February 28, 2005 06:14 AM

Hi, It compiles after I did what you recommended. But a new, valid licensec.licx file is not generated. I have rebuilded and restarted the dev env. in various ways. I have uninstalled 3.1.0.1 Beta and installed it again. When I run the exe standalone or from the dev env. then the docking manager windows are not visible, it is not working. I had this problem also with 3.0.1.0. When I try a CommandBar sample for version 2.1.0.9 then the the developement environment gets strange and keyboard, mouse not working as they should. I must be able to upgrade older versions because I have to be able to upgrade my production application!! I am already past my deadline. I can only pray. Please help soon. Best regards, Böðvar

Administrator [Syncfusion]
Replied On February 28, 2005 09:35 AM

Hi, I apologize, but I left out a step to generate the new licenses.licx file: "Add a ''dummy'' form in your project, and then add some Syncfusion controls onto the form. You could delete the form once the licenses.licx file is regenerated. Also, not all controls need to be added - licensing is done on a per product level, so just one control from each syncfusion assembly that you are using needs to be added." Regards, Gregory Austin Syncfusion Inc.

Administrator [Syncfusion]
Replied On February 28, 2005 11:39 AM

Hi, I have done this and the License.licx file is now generated ok. But I have rebuilt several times and restarted and the problem persists! The problem is when the form is open in design view. If I close the design view of forms that have syncfusion and save, close the dev env. and open it again, then the dev env. is working ok. When I open a design view then the mouse and keyboard are not working as they should. It doesn''t get better until I close the design view save and restart the Visual Stutio dev env. The problem was also like this before the license file fix. For example: I put a button on the dummy form and I cannot move it around after I place it. Can''t move any widget. The dev env is not working as it should, not possible to block text in Code view and auto help is out. #$% I hope that solving this will automatically lead to disappearance of the saving of docking state problem and other issues I have. What can I do? Best regards, Böðvar

Administrator [Syncfusion]
Replied On March 21, 2005 11:26 AM

To generate a new license file, I found that I had to delete the Lincese file - not just the contents of the file.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;