We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Version 3.0 question??

Thread ID:

Created:

Updated:

Platform:

Replies:

23217 Jan 6,2005 01:18 PM Jan 6,2005 02:14 PM Windows Forms 3
loading
Tags: GridControl
Philip Bishop
Asked On January 6, 2005 01:18 PM

Ok I have forgotten this since the last upgrade. What is the CORRECT version of the ConvertResX that i need to run so all of my grids will now come up. Last time we upgraded we had this same problem and i was sent a ConvertResx.exe to run. It didnt work and it turned out i had to have a certain version depening on what i was going from and going to. We are currently at 2.0.5.1 and are trying to run the 3.0.1.0. All of my forms with grids are blowing up when i run and its the same error as last time that made me have to run ConvertResx.exe. You had said it had to do with us using the ide to make our grids VS. doing them in code and that if we did them in code we wouldnt have this problem. So my question is do u have a version that is right for me. I had asked how come u dont install it with ur app last time and noticed this time you did, but i have 3 versions of it. one in a 1.0 folder, another in a 1.1 folder and another in a 2.0.3600 folder all under the migration folder. we are using version 1.1 of the framework. i want to say last time u ended up sending me the code and i had to compile it. Can you help me out. Im DYING to see if some things have been fixed for us.

Philip Bishop
Replied On January 6, 2005 01:34 PM

ok just to follow up. i did some reading and found that i should run the 1.1 version of the conversion tool. i ran the tool..selected all my resx files that had grids on them and then brough up the project. now i dont have any cells showing on my grids at all and they all say global mode..before i would see the cell gridlines and global mode and i immediatly get errors now when i try to build saying this on all forms with grids C:\Net Projects\NO SOURCE SAFE\quasar\frmAGCY_ACCR.resx Resource transformation for file ''frmAGCY_ACCR.resx'' failed. Exception has been thrown by the target of an invocation. i also get this on 3 forms Error reading resources from the resource file for the default culture: Invalid ResX input. and this on another 3 forms Object reference not set to an instance of an object. i remember having similar probs trying to go to 2.1 before we backed up to 2.0.5. i changed the base version to 3.0.1.0 before running the utility also. this is the only version in the gac..any suggestions or does this help any?

Philip Bishop
Replied On January 6, 2005 01:39 PM

one other thing.. i did this through a direct trac with jay last time..here is the number 13353 if i need to again that fine but hoped you might know here first

Administrator [Syncfusion]
Replied On January 6, 2005 02:14 PM

Here is a link to a project with source code for the convertresx utility. You can compile the exe on your system and this should guarantee that the version is compatible with your installtion. http://64.78.52.104/support/user/uploads/convertresx632381046512945399.zip In addtion to running the ConvertResx, you should also check the license.licx file in your project and make sure it has the proper version info as well as the proper Assembly name as these assembly names changed with 3.0. You can do this with a text editor or use global-find-in-files in Visual Studio to pull up these files to check them all at once. Something new to 3.0 that should have a positive inpact on all future releases is that the grid will no longer save binary resources. Instead, it will serialize all settings in designer generated code that should be immune to the ConvertResX requirements in the future. If you open a form in the designer and click on the GridControl, you will see a Touch Me verb under the property grid. When you click that, this will remove any binary grid resources and generate the necessary code. It will also update the licx file to the proper contents.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;