We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Lost Focus

Thread ID:

Created:

Updated:

Platform:

Replies:

21612 Nov 16,2004 07:06 AM UTC Nov 16,2004 08:34 AM UTC Windows Forms 1
loading
Tags: GridControl
Tarun Gujral
Asked On November 16, 2004 07:06 AM UTC

Pls find here in the attached Application. First poopulate the table by clicking populate button. Now select the topmost row, the scroll bar moves focus to some pother row and this behaviour is persistent. How do i disable the focus uch that row scroll doesnot move to that position. Syncfusiontestapps_749.zip

Administrator [Syncfusion]
Replied On November 16, 2004 08:34 AM UTC

When you set style.Enabled = flase, you are indicating you do not want that cell to ever become the current cell. If all such cells are like this, then there is a problem and the grid cannot move teh current position. That is why teh grid is always trying to display the triangle row after you click another row. I think you can get the behavior you want by not handling QueryCellInfo, but instead handling CurrentCellActivating and setting e.ColIndex = 0. Here is your sample back with this change. forumscroll_4406.zip

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;