We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Assembly Manager bug

Thread ID:

Created:

Updated:

Platform:

Replies:

21519 Nov 12,2004 10:59 AM Nov 24,2004 05:43 PM General Discussion 6
loading
Tags: General Discussion
Michel T Dallaire
Asked On November 12, 2004 10:59 AM

I have a problem. I installed V3.0.0.11. And when I try to execute the Assembly Manager, it stays on the Initializing Assembly window with the square moving. But nothing append even after 3 min. When I do a task manager, End Task. The window finaly appear, but it closes right after the opening since I asked for an End Task. So I tried the old one of my 2.0.5.1, and It now have the same problem. I rebooted, but it changed nothing. I''m on WinXP sp2. VS2003. Thank you.

Daniel Jebaraj [Syncfusion]
Replied On November 12, 2004 01:05 PM

Hi Michel, We are looking into this. Do you have version VS.NET 1.0 installed? We think that this happens on machines that have VS.NET 2003 but do not have VS.NET 2002 installed. We just want to be sure this is the configuration you have. Thanks, Daniel >I have a problem. > >I installed V3.0.0.11. And when I try to execute the Assembly Manager, it stays on the Initializing Assembly window with the square moving. But nothing append even after 3 min. > >When I do a task manager, End Task. The window finaly appear, but it closes right after the opening since I asked for an End Task. > >So I tried the old one of my 2.0.5.1, and It now have the same problem. > >I rebooted, but it changed nothing. > >I''m on WinXP sp2. VS2003. > >Thank you. > >

Administrator [Syncfusion]
Replied On November 12, 2004 01:14 PM

Hi Michel, It is possible that the help is being updated during this time. To see if this is the case, please start Visual Studio, and browse out to the Help Contents. If the dialog stating that help is being updated pops up, then let this proceed. When it is done, please close Visual Studio and try running the Assembly Manager again. Also, please note that this would be for both VS.Net2002 and VS.Net2003 (if they are installed). Thanks, Trampas

Michel T Dallaire
Replied On November 12, 2004 02:07 PM

I don''t have VS2002, you are right. I started VS2003, I had the updating HELP sequence. But it has not effect on the assembly Manager. Still the same bug.

Michel T Dallaire
Replied On November 12, 2004 02:14 PM

I have been able to catch that JIT error before the window is close by the End Task: See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box. ************** Exception Text ************** System.NullReferenceException: Object reference not set to an instance of an object. at SFAssemblyManager.SwapUtilityDlg.CleanTab(ToolBox toolbx) at SFAssemblyManager.SwapUtilityDlg.On_Ok(Object sender, EventArgs e) at SFAssemblyManager.SwapUtilityDlg.On_Ok(Object sender, EventArgs e) at System.Windows.Forms.Control.OnClick(EventArgs e) at System.Windows.Forms.Button.OnClick(EventArgs e) at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent) at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) at System.Windows.Forms.Control.WndProc(Message& m) at System.Windows.Forms.ButtonBase.WndProc(Message& m) at System.Windows.Forms.Button.WndProc(Message& m) at System.Windows.Forms.ControlNativeWindow.OnMessage(Message& m) at System.Windows.Forms.ControlNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) ************** Loaded Assemblies ************** mscorlib Assembly Version: 1.0.5000.0 Win32 Version: 1.1.4322.2032 CodeBase: file:///c:/windows/microsoft.net/framework/v1.1.4322/mscorlib.dll ---------------------------------------- AssemblyManager Assembly Version: 1.0.1770.23247 Win32 Version: 1.0.1770.23247 CodeBase: file:///C:/Program%20Files/Syncfusion/Essential%20Suite/3.0.0.11/Utilities/Assembly%20Manager/2003/assemblymanager.exe ---------------------------------------- System.Windows.Forms Assembly Version: 1.0.5000.0 Win32 Version: 1.1.4322.2032 CodeBase: file:///c:/windows/assembly/gac/system.windows.forms/1.0.5000.0__b77a5c561934e089/system.windows.forms.dll ---------------------------------------- System Assembly Version: 1.0.5000.0 Win32 Version: 1.1.4322.2032 CodeBase: file:///c:/windows/assembly/gac/system/1.0.5000.0__b77a5c561934e089/system.dll ---------------------------------------- EnvDTE Assembly Version: 7.0.3300.0 Win32 Version: 7.00.9466 CodeBase: file:///c:/windows/assembly/gac/envdte/7.0.3300.0__b03f5f7f11d50a3a/envdte.dll ---------------------------------------- System.Drawing Assembly Version: 1.0.5000.0 Win32 Version: 1.1.4322.2032 CodeBase: file:///c:/windows/assembly/gac/system.drawing/1.0.5000.0__b03f5f7f11d50a3a/system.drawing.dll ---------------------------------------- System.Data Assembly Version: 1.0.5000.0 Win32 Version: 1.1.4322.2032 CodeBase: file:///c:/windows/assembly/gac/system.data/1.0.5000.0__b77a5c561934e089/system.data.dll ---------------------------------------- System.Xml Assembly Version: 1.0.5000.0 Win32 Version: 1.1.4322.2032 CodeBase: file:///c:/windows/assembly/gac/system.xml/1.0.5000.0__b77a5c561934e089/system.xml.dll ---------------------------------------- ************** JIT Debugging ************** To enable just in time (JIT) debugging, the config file for this application or machine (machine.config) must have the jitDebugging value set in the system.windows.forms section. The application must also be compiled with debugging enabled. For example: When JIT debugging is enabled, any unhandled exception will be sent to the JIT debugger registered on the machine rather than being handled by this dialog.

Michel T Dallaire
Replied On November 15, 2004 07:48 AM

I magane to put the binaries by hand. But I have a strage problem. The HTML_UI. It''s not working either way using a new projet, starting from sample code, or sample binaries. The window stays gray. It compiles and execute correctly, but I often get the error "variable not set to an instance of an object". And that even in the samples. I never have been able to make it work even one time.

Michel T Dallaire
Replied On November 24, 2004 05:43 PM

I installed v3.0.0.19rc and still have the same 2 problems about HTML_UI and Assembly manager. >I magane to put the binaries by hand. > >But I have a strage problem. > >The HTML_UI. It''s not working either way using a new projet, starting from sample code, or sample binaries. > >The window stays gray. It compiles and execute correctly, but I often get the error "variable not set to an instance of an object". And that even in the samples. > >I never have been able to make it work even one time.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;