We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Focus rectangle

Thread ID:

Created:

Updated:

Platform:

Replies:

19263 Sep 22,2004 10:17 AM UTC Sep 22,2004 07:08 PM UTC WinForms 6
loading
Tags: GridControl
Irina
Asked On September 22, 2004 10:17 AM UTC

Hi Clay, Could you please advice on the following problem: I have two databound grids on one tab. When I move from cell to cell of the same grid, everything is OK. But when I click the cell on the second grid, the cell of the first grid which was just left keeps a dotted rectangle. Is there a way not to have that rectangle? Thanks in advance.

Administrator [Syncfusion]
Replied On September 22, 2004 11:13 AM UTC

The ShowCurrentCellBorderBehavior controls this behavior. Try this setting: this.gridDataBoundGrid1.ShowCurrentCellBorderBehavior = GridShowCurrentCellBorder.WhenGridActive;

Irina
Replied On September 22, 2004 11:55 AM UTC

I set that property in designer. It doesn''t help...

Administrator [Syncfusion]
Replied On September 22, 2004 01:07 PM UTC

Try GridShowCurrentCellBorder.AlwaysVisible Then the frame will always be drawn. Stefan

Irina
Replied On September 22, 2004 01:36 PM UTC

still doesn''t work... Which properties settings in the code could affect that? Thanks

Administrator [Syncfusion]
Replied On September 22, 2004 06:10 PM UTC

Does setting ShowCurrentCellBorderBehavior to other settings affect the appearance in any way? This is the property that should control how/when you see the currentcell framed. If you do a search in your code for ShowCurrentCellBorderBehavior, it only shows up once for each grid in the designer code, and no where else? Can you post a sample project showing the problem?

Irina
Replied On September 22, 2004 07:08 PM UTC

That property did not appear in designer code at all when I set it in form designer. It is strange... So I set it in designer code directly and now it works. Thanks

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;