We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

str.match is not a function

I'm using Gantt diagram and I updated my Syncfusion version to  21.1.35
Step 1:  I have removed node_modules folder totally
Step 2:  I removed package.json file
Step 3:  I run npm cache clean --force
Step 4:  Reinstalled my Syncfusion packages with version  21.1.35 via npm install

It didn't work 
Step 4: I run command npm run dedupe
But it still didn't work. After all these steps I still have the following error

My versions of Syncfusion packages

    "@syncfusion/ej2-angular-gantt": "21.1.35",
    "@syncfusion/ej2-angular-navigations": "21.1.35",
    "@syncfusion/ej2-angular-richtexteditor": "21.1.35",
    "@syncfusion/ej2-base": "21.1.35",

I will appreciate any help. Thanks

4 Replies 1 reply marked as answer

UA Udhayakumar Anand Syncfusion Team April 24, 2023 11:18 AM UTC

Hi Aaron

Thank you for reaching out to us. We are unable to replicate the issue that you reported on our end. We've included a sample using the taskbar template and taskID as a string with the version that you’ve mentioned.

In order to investigate this further, could you please provide us with the following details?

  1. Code Snippet of template that you’re using
  2. ViewType of the Gantt
  3. Code Snippet of any other customization you used to render the gantt
  4. Video demonstration of the issue
  5. Code snippet of data source
  6. Could you please modify the given sample and replicate the issue, which will be helpful for us to validate further

Sample Link : https://stackblitz.com/edit/angular-d7ubbw?file=src%2Fdata.ts



AA Aaron replied to Udhayakumar Anand April 25, 2023 10:57 AM UTC

I also wasn't able to reproduce the bug in stack blitz

But I fully copy pasted the whole your example (including all settings) into my app and I still got the same error which is likely to be connected with inserting ng-template into gantt because for that template instead of string I have in variable ElementRef

AA Aaron April 26, 2023 08:08 AM UTC

If somebody will read this topic who also has this issue, I found solutıon - there was issue with versions which maybe are not compatible or I don't know what was the problem

But this instruction for updating helped me (DON'T CHANGE MANUALLY VERSIONS IN PACKAGE JSON):

Marked as answer

UA Udhayakumar Anand Syncfusion Team April 26, 2023 08:48 AM UTC


Hope that your reported problem has been resolved by upgrading packages. Please get back to us if you are facing any difficulties



Live Chat Icon For mobile
Up arrow icon