We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

ActivateCurrentCellBehavior

I am having trouble with the ActivateCurrentCellBehavior when set to DblClickOnCell. "EditBox" , "MonthCalendar" ect… do not activate when double clicked and are in a non scrolling row. Rather than confuse the issue with what I am doing, the same behavior can be seen in your GDBGMultiHeader example. If you take your GDBGMultiHeader example, change the line in the Form1_Load method that has: this.gridDataBoundGrid1.Model.Options.ActivateCurrentCellBehavior = GridCellActivateAction.SelectAll; to: this.gridDataBoundGrid1.Model.Options.ActivateCurrentCellBehavior = GridCellActivateAction.DblClickOnCell; and then run the example and double click on row 2 with the cell having style.CellType = "MonthCalendar" the control is not in edit mode as it should be. This is the case for “EditBox” as well, and probably other controls with an editable text aspect. Is this a known problem ? I can work around the problem with someting like: private void eh_gridDoubleClick(object sender, EventArgs e) { if(m_grid.CurrentCell.RowIndex == 1 && m_grid.ActivateCurrentCellBehavior == GridCellActivateAction.DblClickOnCell && !m_grid.CurrentCell.IsEditing) { m_grid.CurrentCell.BeginEdit(); } } Thanks in advance. Toby Altman

1 Reply

AD Administrator Syncfusion Team November 20, 2002 06:33 AM

Thanks for bringing this to our attention. The GridDataBoundGrid was handling OnCellDoubleClick for any header cell and canceling the event (because of double-click/sort column logic). We will fix this with our next patch. Stefan

Loader.
Live Chat Icon For mobile
Up arrow icon