We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Double value changes to Exponential

Thread ID:

Created:

Updated:

Platform:

Replies:

16623 Jul 21,2004 06:49 AM UTC Jul 21,2004 07:17 AM UTC WinForms 1
loading
Tags: GridControl
K Sengupta
Asked On July 21, 2004 06:49 AM UTC

Hi, I am facing a problem where one of my column is of decimal type which can accept values upto 38 digits and 10 precision after the decimal point.The problem is when I insert a big number it is automatically converted to its exponential form.I want to prevent this from happenning.Please suggest me a solution to it. Regards,

Administrator [Syncfusion]
Replied On July 21, 2004 07:17 AM UTC

What do you mean by ''inserting'' a big number? I tried typing a 1234567890123456789.1234567890 into a column whose style.CellValueType = typeof(double);, and could not see it change to exponential format. If you mean pasteing into the cell, I tried that as well. Now excel will not handle a number with that many significant digits, but if I typed such a number into NotePad and then copied it, I could paste it into the column without seeing the E-Format. So, for me, the decimal values did not lose their formatting when they were entered into the grid. You might try setting style.Format = "#.############"; for the column to see if that handles the problem. If it does not, can you tell me how to see the problem in one of our samples, or can you post a sample project showing the problem.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;