We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Imagery Layer OSM coming as blank

Thread ID:

Created:

Updated:

Platform:

Replies:

150404 Jan 6,2020 08:36 AM UTC Feb 14,2020 08:43 PM UTC Xamarin.Forms 11
loading
Tags: SfMaps
Anukriti
Asked On January 6, 2020 08:36 AM UTC

I am using imagery Layer with OSM to plot markers, but the map is not rendering, just able to see the markers.

<maps:SfMaps x:Name="sfmap"  BackgroundColor="White">
            <maps:SfMaps.Layers>
                <maps:ImageryLayer LayerType="OSM">
                    <maps:ImageryLayer.MarkerSettings>
                        <maps:MapMarkerSetting IconColor="Red" 
                                    IconSize="13" MarkerIcon="Diamond"/>
                    </maps:ImageryLayer.MarkerSettings>
                    <maps:ImageryLayer.Markers>
                        <maps:MapMarker  Label="United States" Latitude="40"
                                            Longitude= "-101"/>
                        <maps:MapMarker Label="Brazil" Latitude="-15.7833" 
                                            Longitude= "-52" />
                        <maps:MapMarker Label="Congo" Latitude="-1.6" 
                                            Longitude= "24.4" />
                        <maps:MapMarker Label="Kazakhstan" Latitude="49.9" 
                                            Longitude= "72.23" />
                        <maps:MapMarker Label="Australia" Latitude="-20.54"
                                            Longitude= "134.10" />
                    </maps:ImageryLayer.Markers>
                </maps:ImageryLayer>
            </maps:SfMaps.Layers>
        </maps:SfMaps>

Also added the screenshot for reference.

Attachment: imageryLayer_47fccddb.zip

James Lavery
Replied On January 6, 2020 08:05 PM UTC

I'm seeing the same thing. This is with an app which was previously successfully showing OSM maps on both Android and iOS.

I was using version 17.3.0.33 - upgrading to 17.4.0.40 hasn't fixed it.

This is using Xamarin.Forms 4.3.0.991221

James Lavery
Replied On January 6, 2020 10:49 PM UTC

Switching to Bing maps (having obtained a basic key) works. So it appears to be a problem only with OSM maps.

Anukriti
Replied On January 7, 2020 03:46 AM UTC

Yeah, experiencing the same behavior. I had a completely functional app with OSM on Android but coming as blank now. And its working fine with Bing.

Rachel A [Syncfusion]
Replied On January 7, 2020 01:37 PM UTC

Hi Anukriti, James, 
 
Greetings from Syncfusion. 
 
We are facing this problem because we are accessing the OSM server internally. So as of now you can access it from RequestTileUri event, as in the below code snippet. 
 
 
[XAML] 
   
<maps:SfMaps> 
        <maps:SfMaps.Layers> 
            <maps:ImageryLayer  RequestTileUri="ImageryLayer_RequestTileUri" LayerType="OSM"> 
                
            </maps:ImageryLayer> 
        </maps:SfMaps.Layers> 
         
    </maps:SfMaps> 
 
 
[C#] 
 
  private void ImageryLayer_RequestTileUri(object sender, Syncfusion.SfMaps.XForms.TileUriArgs e) 
        { 
            var link = "http://a.tile.openstreetmap.org/" + e.ZoomLevel + "/" + e.X + "/" + e.Y + ".png"; 
 
            e.Uri = link; 
        } 
 
We will resolve this problem and include in upcoming weekly NuGet. 
 
Regards, 
Rachel.  


James Lavery
Replied On January 7, 2020 02:08 PM UTC

Thank you - I will try this and let you know if it fixes it.


Anukriti
Replied On January 7, 2020 02:13 PM UTC

Thanks, the map is loading with this explicit call to tile server.

Vignesh Ramesh [Syncfusion]
Replied On January 8, 2020 06:51 AM UTC

Hi Anukriti, James,  

We are glad that the provided workaround solution resolved the problem. As we have mentioned in our previous update, we will resolve this problem in our source and include in upcoming weekly NuGet which will be publish on 14th January 2020. 

Regards, 
Vignesh. 


Anukriti
Replied On January 15, 2020 04:11 PM UTC

Hi Vignesh,

Any updates on this? Is the weekly release available now?

Vignesh Ramesh [Syncfusion]
Replied On January 17, 2020 07:14 AM UTC

Hi Anukriti,  
  
We are glad to announce that our weekly NuGet was rolled out on 14th January 2020 and reported issue was resolved in the weekly NuGet. 
 
NuGet Version: 17.4.0.43
 
We thank you for your support and appreciate your patience in waiting for this release. Please get in touch with us if you would require any further assistance.  
  
Thanks,  
Vignesh. 


Gurpal
Replied On February 13, 2020 10:35 AM UTC

Hi we seem to still be experiencing issues with OSM map layers on Android with the latest Nuget installed. 
If the map appears it does so very slowly, often we are left with a blank (white or blue) screen. Map markers are being drawn onscreen though and tooltips also display correctly.
Also iOS does not suffer from these issues.
We have the same issue on device and simulator and internet connection and speed has been ruled out. 
This app with its map worked perfectly prior to Nov 2019 release. 

Ramya Soundar Rajan [Syncfusion]
Replied On February 14, 2020 08:43 PM UTC

Hi Gurpal, 
 
We have tried to reproduce the reported issue. but we are afraid that we are not able to reproduce the issue at our end.  
 
So, could you please check the issue with the attached sample and let us know whether it is reproduced or not? If the issue was reproduced, please revert us by modifying the sample based on your application along with replication procedure like short video and configuration details, etc. This will be helpful for us to investigate further and provide you a better solution at the earliest. Please find the sample from the following location. 
 
 
Regards, 
Ramya 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon