We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

autocomplete customization inside scheduler editor window

Thread ID:

Created:

Updated:

Platform:

Replies:

150190 Dec 25,2019 02:15 AM UTC Dec 30,2019 11:10 AM UTC Angular - EJ 2 1
loading
Tags: Schedule
jose lara
Asked On December 25, 2019 02:15 AM UTC

    Hi, I previously asked a question about customizing auto complete and it worked as described here - https://www.syncfusion.com/forums/148115/auto-complete-remote-data       


I tried to follow the same example within scheduler editor window, but it doesn't work for me. Can you pls provide a working example showing how I can use autocomplete inside editor window? 


let atcObj: AutoComplete = new AutoComplete({

            dataSource: countries,

            fields: { value: 'text' },           

            placeholder: 'e.g. Algeria',

            popupHeight: '450px',

            highlight: true,

            suggestionCount: 5,

            minLength:3,

           

            select: function (selectArgs){

              console.log('se args:' + selectArgs.itemData);

            },

            

            filtering : function (e: FilteringEventArgs, remote: AutoCompleteComponent){  // Remote obj is always undfined

              if (e.text.length >= this.minLength) {

                this.data = this.clientsService.getUsersAutoComplete(remote, e.text);

                e.preventDefaultAction = true;

              }

              else {

                e.cancel = true;

              }

            }


          });


          atcObj.appendTo(inputEle);

          inputEle.setAttribute('name', 'customerDdl');

          }


Vinitha Devi Murugan [Syncfusion]
Replied On December 30, 2019 11:10 AM UTC

Hi Jose, 
 
Syncfusion Greetings. 
 
Using editorTemplate, we have prepared autocomplete sample and the same can be found in the following link. For better performance, we suggest using query option to filter the data instead of filtering. 
 
Kindly try the above sample and if still the issue persist please make your changes in the same sample and revert us. 
 
Regards, 
M.Vinitha devi 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon