We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

SelectedItem highlight don't move after row deleting

Thread ID:

Created:

Updated:

Platform:

Replies:

150010 Dec 17,2019 07:36 PM UTC Jan 13,2020 05:29 AM UTC WinForms 8
loading
Tags: SfDataGrid
Riad
Asked On December 17, 2019 07:36 PM UTC

I have a strange problem in SfDataGrid. When i add rows into the grid for the first time, the selectedItem move to the last row added but when i delete at least one row from the grid and add again a new row the selectedItem property doesn't work also if remove all items and add a new rows you cannot select the first row using the mouse.
Any fix for that.
An example is attached

Best regards

Attachment: Example_7c74447b.zip

Susmitha Sundar [Syncfusion]
Replied On December 18, 2019 11:10 AM UTC

Hi Riad,  
  
Thank you for using Syncfusion controls.  
  
We can replicate the reported issue and created the bug report for the same. Can you please specify your current Syncfusion version so that We will provide a patch for that version.  
  
You can track the status of this report through the following feedback link,   
   
  
Note: The provided feedback link is private, and you need to login to view this feedback.    
   
Regards,  
Susmitha S  


Riad
Replied On December 18, 2019 05:27 PM UTC

My syncfusion version is : 17.3.0.26

Farjana Parveen Ayubb [Syncfusion]
Replied On December 19, 2019 06:59 AM UTC

Hi Riad, 
 
Thank you for your update. 
 
We will provide the patch for the reported issue on January 2nd, 2020.  
 
We appreciate your patience until then. 
 
Regards, 
Farjana Parveen A  


Riad
Replied On December 19, 2019 01:56 PM UTC

You're welcome

Farjana Parveen Ayubb [Syncfusion]
Replied On December 20, 2019 06:02 AM UTC

Hi Raid, 
 
Thank you for your update. 
 
As we promised earlier, we will provide the fix for the reported issue on January 2nd, 2020. 
 
We appreciate your patience until then. 
 
Regards, 
Farjana Parveen A  


Susmitha Sundar [Syncfusion]
Replied On January 2, 2020 07:36 AM UTC

Hi Riad, 
 
Thank you for your patience. 
 
We have fixed the issue “Selection is not working properly after deleting the records and you can download the patch from following location.  
  v17.3.0.26 
Recommended approach – exe will perform automatic configuration       
Please find the patch setup here:   
Advanced approach – use only if you have specific needs and can directly replace existing assemblies for your build environment                        
Please find the patch assemblies alone from:  
 
Please find the Nugets from the below location:      
 
  
Assembly Version: 17.3.0.26 
Installation Directions:  
This patch should replace the files “Syncfusion.Shared.base” under the following folder.  
$system drive:\ Files\Syncfusion\Essential Studio\$Version # \precompiledassemblies\$Version#\4.0  
Eg : $system drive:\Program Files\Syncfusion\Essential Studio\17.3.0.26\precompiledassemblies\17.3.0.26\4.0  
   
To automatically run the Assembly Manager, please check the Run assembly manager checkbox option while installing the patch. If this option is unchecked, the patch will replace the assemblies in precompiled assemblies’ folder only. Then, you will have to manually copy and paste them to the preferred location, or you will have to run the Syncfusion Assembly Manager application (available from the Syncfusion Dashboard, installed as a shortcut in the Application menu) to re-install assemblies.  
   
Note 
To change how you receive bug fixes, ask your license management portal admin to change your project’s patch delivery mode.  
   
   
Disclaimer:  
If you have received other patches for the same version for other products, please apply all patches in the order received. Please note that we have created this patch for version 17.3.0.26 specifically to resolve the following issue reported in the forum 150010. This fix will be included in our Volume 4 SP1 release which is expected on end of January 2020.  
 
Regards, 
Susmitha S 


Riad
Replied On January 11, 2020 10:01 AM UTC

Thanks a lot synfusion team.

Farjana Parveen Ayubb [Syncfusion]
Replied On January 13, 2020 05:29 AM UTC

Hi Riad, 
 
Thanks for the update. 
 
We are glad to know that the reported problem has been resolved at your end. Please let us know if you have any further queries on this. We are happy to help you. 
 
Regards, 
Farjana Parveen A 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon