We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Scheduler intitial load really, really slow

Thread ID:

Created:

Updated:

Platform:

Replies:

149093 Nov 14,2019 06:30 AM UTC Nov 19,2019 06:41 AM UTC Angular - EJ 2 3
loading
Tags: Schedule
Giruga
Asked On November 14, 2019 06:53 AM UTC



Hi again!

I have come to face an problem, that I am not able to solve by myself.

After trying to make the scheduler act like it should in our little project, I seem to have added .... something that slows the initial load of the scheduler A LOT.

'The page' loads quickly enough (I got the default Loading... text), but then there comes what I think is 'Scheduler loading' - and this loading takes more than 30 seconds.

After the load has been done, the scheduler is responsive and fast again.

The data load happens really fast (I am checking with console.logs etc + the amount of data is quite small (2 groups, ~10 resources, total of 50 appointments)

The data is loaded with forkJoin (4 async calls), piped with .pipe(takeUntil(this.onDestroy))

The schedule elements (with event bindings:)
<ejs-schedule #scheduleObj cssClass='timeline-resource-grouping' [selectedDate]="selectedDate" [group]="group"
      [eventSettings]="eventSettings" [firstDayOfWeek]='1' (actionComplete)="onAction($event)" (popupOpen)="onPopupOpen($event)"
      (resizeStop)="onResizeStop($event)" (dragStop)="onDragStop($event)" (eventRendered)="eventRendered($event)"
      (actionBegin)="onActionBegin($event)" (navigating)="onNavigate($event)">

Views: Agenda, TimelineDay & TimelineWeek, no extra services (only the TimelineViewsService)

Do you have any tips suggestions what to check? I have already investigated the package sizes and analyzed the stats of the whole app - nothing alarming there

As I am quite newbie with Angular, please feel free to check that I have also done all the 'obvious' steps :D

I do realize this is really broad question, but after days of investigating - and not having any answers - I am getting a bit lost

TL;DR; Are there any specific things that make the Scheduler init really slowly? How do You suggest I should tackle them?

Hareesh Balasubramanian [Syncfusion]
Replied On November 15, 2019 01:44 PM UTC

Hi Giruga, 

Greetings from Syncfusion Support. 

We have prepared a sample with 2 groups, 10 resources and with 50 data source but in our schedular takes only a reasonable time (5 sec) for the initial loading and the same can be viewed from the following sample link, 


Note: For loading “n” number of resources, we suggest you to use the virtual scrolling, it will increase the schedular performance for larger resources. Kindly refer the below link, 

Kindly try the above sample, if you have any concerns please revert us back for further assistance. 

Regards, 
Hareesh 


Giruga
Replied On November 18, 2019 09:17 AM UTC

Hi!

And thank you for your reply.

Apparently I was not clear enough in my previous message - the amount of data etc. was 'FYI' info, not the problem. The slowness of init WAS NOT because of data

BUT! A breakthrough happened today. The reason for slowness was this starthour- attribute:
        <e-view option="TimelineDay" displayName="Day" [startHour]='startHour'
          [allowVirtualScrolling]="virtualScroll"></e-view>

By removing it the scheduler started to load in seconds.

Apparently as I had working hours etc that started before the starting hour, and that resulted in some kind of loop? I do not know.

But now it is fast again.

Which leads to the next question: How do I 'scroll' automatically to certain time-period?

I would like to 'scroll' automatically - let's say - to have the scheduler view 'start' at 08:00, but I still need to be able to scroll to earlier timeperiods - is there way to achieve this?

TL;DR; How can I scroll to wanted time 'automatically' after viewInit?

Vinitha Devi Murugan [Syncfusion]
Replied On November 19, 2019 06:41 AM UTC

Hi Giruga, 
 
Thanks for your update. 
 
Q1: We are happy that the problem has been resolved at your end. 
 
Q2: You can manually scroll to a specific time on scheduler by making use of the scrollTo method. Please refer below UG and sample link. 
 
 
Regards, 
M.Vinitha devi 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon