We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

ListView bound to ObservableCollection not updating when inside SfTabView

Thread ID:

Created:

Updated:

Platform:

Replies:

148296 Oct 14,2019 12:59 PM UTC Oct 18,2019 06:46 AM UTC Xamarin.Forms 3
loading
Tags: SfTabView
Mario Henkel
Asked On October 14, 2019 12:59 PM UTC

Greetings,

I'm using SfTabView to host a total of 5 Tabs each with a different ListView withing. Those ListViews are bound to ObservableCollections. If I leave away the SfTabView part in my XAML and only use a ListView as ContentPage.Content the ListView is updating as it should when I add items.

If it is inside a SfTabView, I have to leave the page and enter the Page hosting the SfTabView again to make the changes visible. Since it's working withoug SfTabView I think it may be a issue with SfTabView.

I'll attach some code to help troubleshoot.

Kind regards

Mario

Attachment: SyncFusion_db56263f.7z

Hemalatha Marikumar [Syncfusion]
Replied On October 15, 2019 04:16 PM UTC

Hi Mario, 
 
Greetings from Syncfusion. 
 
We have checked the sample which has been prepared based on the provided code example. We are unable to reproduce the reported issue with the version of both 17.3.0.14 and 17.3.0.17 (Weekly nuget release). Please check the prepared sample from below link. 
 
Sample Link:

 
https://www.syncfusion.com/downloads/support/directtrac/general/ze/TabViewSample-2010929901.zip

If the issue still reproduces, please update us with the following details to check the reported issue further and provide a better solution. 
  • Used Syncfusion SfTabView product version and Xamarin.Forms version
  • Device and system configuration.
  • Share the issue reproducing sample with its replication steps or please share the modified sample of updated one.
  • Any video update to replicate the exact issue
 
Regards,
Hemalatha M. 


Mario Henkel
Replied On October 17, 2019 09:16 AM UTC

Hi Hemalatha,

thanks for your quick feedback! I can confirm that your sample indeed works as expected so I suspect the error must be lying somewhere else in my code.

I'll try to fix it. Thanks for your great support! Much appreciated

Kind regards

Mario

Hemalatha Marikumar [Syncfusion]
Replied On October 18, 2019 06:46 AM UTC

Hi Mario, 
 
Thanks for your update. 
 
We glad to hear that given solution works. 
 
Please let us know if you have any other query. 
 
Regards, 
Hemalatha M. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon